Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
683 Views

Intel i225V Onboard Z490 Slow download speeds?

Hi everyone, 

I just recently built a new PC using an ASUS Z490 Gaming F as my motherboard. The onboard NIC is a Intel i225V 2.5GB. I am experiencing strange throttling in Steam and general Internet speed tests. I have a 500mbps fibre connection and before on my much older pc I would get around 480mbps on pretty much every speed test available, now it's hovering around 150-250mbps. Steam would also download around 48MBps, now it's sticking around 24MBps. 

I have updated the firmware and drivers to newest available. 

As a test, I also installed a cheap TP-Link Nic and all my issues have been resolved using this. So it appears to be an issue with the Intel Nic IMO. Has anyone come across this issue or at least similar? I would rather not have a cheap TP link NIC if my onboard NIC is meant to operate better than this. 

Thanks in advance. Please ask any questions that may help to lead to an answer. 🙂 

Kind regards

0 Kudos
25 Replies
Highlighted
Moderator
673 Views

Re:Intel i225V Onboard Z490 Slow download speeds?

Hi Kiz2694,

Thank you for posting in our Intel® Ethernet Communities Page.

We would like to get the configuration of your system. Please download and run our Intel® System Support from this page, https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-. After downloading, please save the logs to a text file, and attach the file to your reply post.

We look forward to hearing from you. If we do not get your reply, we will follow up after 3 business days.



Best Regards,

Alfred S

Intel® Customer Support


Highlighted
Novice
664 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Hi,

I also have the same issue with my Asus Strix Z490i, I get an average of 500 Mbps download on WiFi but 100 Mbps using the LAN port. I'm plugged into my Netgear GS810EMX switch that is connected to another GS810EMX downstairs. I have already tried connecting using the other ports and different ethernet cables.

Highlighted
Novice
652 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Wow, I'm actually glad someone is having the same issue I was going mad!

@AlfredoS_Intel please find attached my logs from SSU. Worth adding I'm just plugged straight into my broadband router no switches. My motherboard is an Asus Z490 Gaming F so part of the same series of MBs as mentioned above. Thanks in advance. 

0 Kudos
Highlighted
Moderator
643 Views

Re:Intel i225V Onboard Z490 Slow download speeds?

Hi kiz2694 and Drew206 ,

Thank you for your responses.

Please allow us some time to check on this.

While we are checking, please try to tune your ethernet adapters, and see if you can get a much faster speed. Please refer to this page, https://www.intel.com/content/www/us/en/support/articles/000005811/network-and-i-o/ethernet-products..., for more information on the settings that you can change to improve throughput performance.

Looking forward to your reply, and we will also update you no later than 3 business days from now, if we found out something.

As an additional question, have you also tried the drivers from your respective board models?


Best Regards,

Alfred S

Intel Customer Support 


0 Kudos
Highlighted
Novice
636 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Hi @AlfredoS_Intel 

I have actually already run through the optimize guide and nothing seemed to improve the speed. 

@Drew206  Not sure if it helped you? 

Thanks again. 

0 Kudos
Highlighted
Moderator
631 Views

Re:Intel i225V Onboard Z490 Slow download speeds?

 Hi Kiz2694,

Please try to update your driver to the latest version, https://downloadcenter.intel.com/download/22283/Intel-Ethernet-Adapter-Complete-Driver-Pack?product=.... We are not highly optimistic that it will solve the issue since Drew206, already has that version on his system. Nevertheless, please try if there will be any improvements.

If there is still no improvements, please try to disable the following advanced settings. You might have stumbled on these settings when we ask you to try our last recommendations. Please disable these settings:

LsoV2IPv4:Large Send Offload V2 (IPv4):"Enabled (1)"

LsoV2IPv6:Large Send Offload V2 (IPv6):"Enabled (1)"

Please check if it will remain the same.

If it remains the same, please put the above settings back to what they were , and will try to mimic the settings from your TP link ethernet adapter, since that one runs well. Please change the following settings:

Please turn this off or disable it : EEELinkAdvertisement:Energy Efficient Ethernet:"On (when system is in S0, S0ix and Sx) (1)"

Please do the same for this one, EnablePME:Enable PME:"Enabled (1)",

Change *ReceiveBuffers:Receive Buffers:" to 512

Change *TransmitBuffers:Transmit Buffers:"128"

After doing the above items, please check if there will be any improvements.

Hi Drew206,

We are waiting for your reply, if you have already tested tuning the ethernet adapter. If you did not get improvements, please also try the above recommendations


Best Regards,

Alfred S

Intel Customer Support  


0 Kudos
Highlighted
Novice
633 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Hi @AlfredoS_Intel 

I have run the driver update but it only asked to modify which is what I selected, so I assume I already had the drivers installed. 

I have also tried all of your recommendations but nothing seemed to improve it compared to the tplink nic. Recent results: 

On Intel:

Google Speedtest: 160mbps

Speedtest.net: 380mbps

Steam Download: Peak 29MBpps (around 290mbps)

On Tplink:

Google Speedtest: 430mbps

Speedtest.net: 505mbps

Steam download: Peak 51MBps (around 500mbps) 

Later today I'm going to try with a CAT6 Cable from my work to see if it helps. 

Thanks above.

 

 

0 Kudos
Highlighted
Novice
642 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Hey

I was able to fix my NIC speed by changing the Speed & Duplex value from Auto Negotiation to 2.5 Gbps Full Duplex. I'm getting 900 Mbps average download from ethernet now.  Maybe this will work for you Kiz? Good Luck!

0 Kudos
Highlighted
Novice
632 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Hi @Drew206

That’s good news! I will try when I get home, are the switches you’re connecting to 2.5gbps capable? My router obviously isn’t so not sure if this will be the fix for me.

Thanks

Kind regards,
0 Kudos
Highlighted
Novice
633 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

My switch is multi gig capable but I confirmed that it works fine on the regular gigabit ports as well.
0 Kudos
Highlighted
Novice
614 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

I'm having the exact same issue with my new Asus Z490-F Gaming motherboard. I tried @Drew206 's suggestion setting the Speed and Duplex value but that didn't resolve the issue. @Drew206 what driver version are you running? Perhaps I need to upgrade/downgrade as well.

0 Kudos
Highlighted
Novice
606 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

For anyone else coming this this thread, I fixed mine by installing the Intel v1.45 firmware update that is packaged with the network driver on Asus's website. I did NOT install the updated Asus driver -- still running v1.0.0.13 of the Asus driver and Speed & Duplex setting is left on Auto Negotiate. Speeds are back to normal.

0 Kudos
Highlighted
Novice
603 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Hi everyone, 

Think I might be getting somewhere, after setting link speed to 2.5 and using a cat6 cable speeds have generally increased.... still slow on Googles Speedtest ...but managed 500mbps on Speedtest.net. 

Still not confident it's working better than the TP-link nic. 

I have flashed the new firmware but that didn't seem to fix it much more than the above has. Is there any way to check the firmware went through ok? the CMD prompt gave an error at the end which in the guide it seemed to ignore...

thanks guys

Kind regards,

 

Highlighted
Novice
601 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

I also had an error at the end of the firmware update (some red text complaining about a regular expression issue). After the firmware update I turned off the PC and unplugged it, waiting a minute and powered back on like the directions said. I was able to hit my max connection speed (~500Mb) when I booted back up. I did *not* upgrade the driver and am still running 1.0.0.13.

Highlighted
Novice
578 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Asus z490 Prime-A here, with an i7-10700. 

Updated to firmware 1.45, updated BIOS to 0704, and tried driver 1.0.0.13, 1.0.0.14, and 1.0.0.17. 

Still slogging with a slow connection. 

0 Kudos
Highlighted
Novice
576 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

@kiz2694 I also got the strange error at the end of the firmware upgrade. But after checking it with the update.bat file, it showed a successful update to 1.45. 

 

Tags (1)
0 Kudos
Highlighted
569 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

I was able to fix the same problem by adjusting these settings:

 

Change *Receive Buffers* to 1024

Change *Transmit Buffers* to 1024

 

This put me back up to my expected speeds

0 Kudos
Highlighted
Novice
566 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Thanks for the suggestion. Unfortunately I'd already adjusted those as well. 

I ran through all of the suggested changes from earlier in the thread. No luck.

LsoV2IPv4:Large Send Offload V2 (IPv4):"Enabled (1)"

LsoV2IPv6:Large Send Offload V2 (IPv6):"Enabled (1)"

Please turn this off or disable it : EEELinkAdvertisement:Energy Efficient Ethernet:"On (when system is in S0, S0ix and Sx) (1)"

Please do the same for this one, EnablePME:Enable PME:"Enabled (1)",

Change *ReceiveBuffers:Receive Buffers:" to 512

Change *TransmitBuffers:Transmit Buffers:"128"

0 Kudos
Highlighted
Novice
554 Views

Re: Re:Intel i225V Onboard Z490 Slow download speeds?

Hi guys, I’m still getting odd speeds, thought I had got somewhere with the CAT6 cable and firmware update but still seems slower than the tp link nic. I’m currently with the newest drivers and firmware and using a CAT6 cable. Still getting odd download tests and slower than normal steam downloads.

Kind regards
0 Kudos