Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4633 Discussions

Onboard Intel I219-LM PTP synchronization problem ( Driver e1000e 3.8.7 )

Reha
Beginner
926 Views

Hello,

 

I have a an Intel  I219-LM on board ethernet adapter on Asus  pro q670m-c-csm motherboard. This is debian Linux, the ethernet driver is e1000e 3.8.7 . It looks that the NIC PTP clock is working.

But when i try to synchronize with the master clock i have the below output from ptp4l service

 

INITIALIZING to LISTENING on INIT_COMPLETE
port 1: new foreign master 6c13d5.fffe.2a157c-4
selected best master clock 00b0ae.fffe.03e70d
updating UTC offset to 37
port 1: LISTENING to UNCALIBRATED on RS_SLAVE
port 1: minimum delay request interval 2^1
master offset 1131758971068 s0 freq +23999998 path delay -471334013
master offset 1132734602045 s1 freq +23999999 path delay -323203787
master offset 1123360235 s2 freq +23999999 path delay -323203787

port 1: UNCALIBRATED to SLAVE on MASTER_CLOCK_SELECTED
clockcheck: clock jumped forward or running faster than expected!
master offset 2175868319 s0 freq +23999999 path delay -252103953
port 1: SLAVE to UNCALIBRATED on SYNCHRONIZATION_FAULT
clockcheck: clock jumped forward or running faster than expected!
master offset 3299624842 s0 freq +23999999 path delay -252103953
clockcheck: clock jumped forward or running faster than expected!
master offset 4437440631 s0 freq +23999999 path delay -266125793
clockcheck: clock jumped forward or running faster than expected!
master offset 5561166849 s0 freq +23999999 path delay -266125793

 

And never get synchronize with the master clock.

I had to modify the ptp4.conf and set the timestamping to software then it works. But without hw timestamping .

 

For the NIC Intel I219-LM and e1000e driver it says that hw timestamping is allowed. But as far as i can see  its not.

 

Is there a solution for that ?  

0 Kudos
5 Replies
KN_XYZ
Beginner
772 Views

Hello,

 

I have a very similar problem.

I'm using Dell Precision 7770 with I219-LM, running Ubuntu 22.04 LTS.

It looks like the NIC PTP clock is running way too fast and the frequency adjustments driven by ptp4l are insufficient. Similarly to Reha I see "freq +23999999" so it is trying to adjust but the master offset keeps increasing.

Checking the NIC PTP clock manually (sudo phc_ctl /dev/ptp0 get) I see that the clock is running about 50% too fast, that is within 2 minutes interval it would advance by 3 minutes.

 

Reha, have you managed to sort that issue out?

Any suggestions on this?

Thanks

0 Kudos
Reha
Beginner
760 Views

Hello,

 

Unfortunately I219-LM is not suitable for ptp clock. So we have moved to Intel I210-AT as a separate ptp NIC card.

 

Intel i210-AT , i210-T1  or i350T series can be used for ptp clocking.

 

Regards,

 

 

0 Kudos
KN_XYZ
Beginner
752 Views

Hi Reha,

Thanks for very quick reply!

 

What do you mean by "not suitable", do you have any more details on this that you could share please?  I219-LM is listed everywhere as PTP capable and it has hardware timestamping option so I was expecting it to work.

 

I happen to also have an Intel NUC with built-in I219-V and this one seems to work fine.

0 Kudos
Reha
Beginner
739 Views

I wanted to correct me. 

 

You can do PTP by software timestamping using i219-LM . i219-LM is not suitable for PTP hardware timestamping. 

0 Kudos
engnfrc
Beginner
600 Views

I too am running into this issue when using the I219-LM. I would really like to get hardware timestamping to work since the machine I'm working on is acting as a grandmaster clock and needs to communicate on multiple NICs. /dev/ptp2 belongs to the I219-LM in question and /dev/ptp0 belongs to an I225-IT, which is working as expected. I don't know if the below output helps at all, but I've never inspected the /dev/ptp files and these bits feel like they could help. I do have another machine that's 5-10 years old (new machine is only a few months old) with an I219-LM, but I don't see this misbehavior there. Both are running Ubuntu 20.04 but the old machine is kernel 5.4.0-42-lowlatency and older packages versus the new machine 5.15.0-72-lowlatency with newer packages, linuxptp appears to be the same on each.

sudo phc_ctl /dev/ptp2 caps
phc_ctl[31649.778]:
capabilities:
23999999 maximum frequency adjustment (ppb)
0 programable alarms
0 external time stamp channels
0 programmable periodic signals
doesn't have pulse per second support

sudo phc_ctl /dev/ptp0 caps
phc_ctl[31652.071]:
capabilities:
62499999 maximum frequency adjustment (ppb)
0 programable alarms
2 external time stamp channels
2 programmable periodic signals
has pulse per second support

sudo phc_ctl /dev/ptp2 freq
phc_ctl[31660.593]: clock frequency offset is -23999998.992920ppb

sudo phc_ctl /dev/ptp0 freq
phc_ctl[31665.443]: clock frequency offset is 9131.210327ppb

0 Kudos
Reply