FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5984 Discussions

Cyclone V GX: cant't connect Rapidio II IP and Transceiver Reconfiguration Controller

Altera_Forum
Honored Contributor II
1,221 Views

Hello, I'm using Cyclone V GX to interface with RapidIO II. 

 

I met a problem with using RapidIO II IP and Transceiver Reconfiguration Controller in Qsys.  

When I connect its reconfig_from_xcvr and reconfig_to_xcvr signals there are 4 errors in messages: 

 

rapidio2_0.reconfig_from_xcvr has a export signal, but alt_xcvr_reconfig_0.reconfig_from_xcvr does not. 

rapidio2_0.reconfig_to_xcvr has a export signal, but alt_xcvr_reconfig_0.reconfig_to_xcvr does not. 

alt_xcvr_reconfig_0.reconfig_from_xcvr has a reconfig_from_xcvr signal, but rapidio2_0.reconfig_from_xcvr does not. 

alt_xcvr_reconfig_0.reconfig_to_xcvr has a reconfig_to_xcvr signal, but rapidio2_0.reconfig_to_xcvr does not. 

 

If I add RapidIO (Gen1) IP instead RapidIO II, these errors don't appear. 

Quartus II version is 13.1 Build 162. 

 

Thanks
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
180 Views

Solution found! Just tried it at home desktop with Quartus II 15.0 and errors wasn't appeared. 

Thread may to be closed. Thanks :D
Altera_Forum
Honored Contributor II
180 Views

Can you show me how to solve this problem. I meet the same problem.

Reply