FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
6383 Discussions

Quartus installation not found: some functionality will not be available until you set QUARTUS_ROOTD

Sreejith_TV
Beginner
897 Views

I am trying to run the DSP Builder verify option from Simulink DSP Builder menu. But, I am getting this error.

Sreejith_TV_1-1683032564120.png

 

 

I have checked the root directory from MATLAB command window,  getenv('QUARTUS_ROOTDIR'), and it shows the correct directory, i.e., /home/user_name/intelFPGA_pro/21.3/quartus/bin

 

Please help to resolve this issue.

 

 

0 Kudos
1 Solution
Nurina
Employee
803 Views

Hello,


Are you sure the Quartus installation directory should be in ./bin?

In page 21 of the guideline the default installation is in /opt/intelfpga<version>/quartus


Please check for the correct installation directory. Also, may I know which OS you are using?


Regards,

Nurina


View solution in original post

0 Kudos
4 Replies
Nurina
Employee
867 Views

Hi,


Did you get this after running dsp_builder.sh in command prompt?


0 Kudos
Sreejith_TV
Beginner
853 Views

Hi,

I followed the steps provided in the section 2.3 of Handbook. (https://www.intel.com/content/www/us/en/docs/programmable/683337/23-1/faq.html) .

The following are the steps in detail.

 

1. Open the terminal from the dspba folder. 

           cd ~/intelFPGA_pro/21.3/quartus/dspba

 

2. Run dspbuilder.sh from terminal.

         ./dsp_builder.sh - m /usr/local/MATLAB/R2019a/

         Matlab opens with the following notification

          Sreejith_TV_0-1683102360732.png

 

3. Then, after pressing OK, I started simulink.

 

4. From the DSP Builder tab on simulink new file window, open an example file. The simulation is working fine.

                   Sreejith_TV_2-1683102697441.png

 

5. Then Design checker option from DSP Builder menu is working fine.

                  Sreejith_TV_3-1683102998656.png

 

6. Then the verify design option from DSP Builder menu, brings the error again.

                  Sreejith_TV_4-1683103370015.png

 

Thank you,

Sreejith

 

 

 

 

0 Kudos
Nurina
Employee
804 Views

Hello,


Are you sure the Quartus installation directory should be in ./bin?

In page 21 of the guideline the default installation is in /opt/intelfpga<version>/quartus


Please check for the correct installation directory. Also, may I know which OS you are using?


Regards,

Nurina


0 Kudos
Nurina
Employee
746 Views

Hello,

 

I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, please login to https://supporttickets.intel.com , view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


p/s: If any answer from community or Intel support are helpful, please feel free to mark as solution, give Kudos and rate 4/5 survey


Regards,

Nurina


0 Kudos
Reply