FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5961 Discussions

Cyclone 10GX JTAG Programming

KBhag3
Novice
8,224 Views

Hi, I am using Cyclone 10GX in one of my design. When I started testing my board, JTAG was not functioning properly. I could program Cyclone10 through JTAG at 1MHz but not beyond that.

 

I tried different pull up values for TMS & TDI (10K, 4.7K & 1K) but the response is same in all cases. Even at 1 MHz, I couldn’t program Micron Flash device.

I checked back my layout & below are the net lengths in the PCB.

 

JTAG_TCK: 3.3 inch

JTAG_TD0: 2.9 inch

JTAG_TMS: 2.7 inch

JTAG_TDI: 2.8 inch

 

I believe 0.5 inch trace length difference should not create any issues at 24 MHz JTAG speed.

 I have attached my Schematics page. Please let me know if you have any suggestions for this issue.

 

Best regards,

Bhagavath

0 Kudos
24 Replies
KBhag3
Novice
1,114 Views

Dear Anand,

 

I tried this but status is same.

 

Best regards,

Bhagavath

0 Kudos
Afari6
Beginner
1,114 Views

Hi,

I don't know if your problem is resolved but i read somewhere (i don't remember the document) that in fast mode (MSEL = 010) density need to be > 256Mb OR > 512Mb.

Perahps that can help you.

0 Kudos
KBhag3
Novice
1,114 Views

Hi,

 

Thanks for your reply. I just changed the Flash with a new device & it started working.

 

Best regards,

Bhagavath

KBhag3
Novice
1,114 Views

Actually it started working in first board when I removed 10K pullup from D0 & D1 lines of configuration Flash.

0 Kudos
Reply