Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,023 Views

Cyclone V SoC dev kit - Ethernet and USB host port not working

Cyclone V SoC dev kit, rev C board. 

 

Straight out of the box, I tried connecting to our dev ethernet network which has a DHCP server, but the board does not get an IP. Using Wireshark we saw no packets coming from the device at all but on the switch, we see a good link status at 1Gbps, duplex. Why doesn't it request an IP? 

 

Next I tried getting the USB to work on a Windows 7 32 bit machine. After the board is all powered up and it says "No IP obtained, Hello Tim", I connect the USB cable to the host and Windows says the device is unknown. I went through the Altera documentation which says to go to the Device Manager, update software, blah blah blah, but still no luck. I still see USB device unknown. Windows detects something is there but I can't get the driver (supplied by Quartus install) to work. I also tried installing the driver directly from FTDI but it also made no difference, even though the FTDI driver install went smoothly. 

 

Next I tried getting USB working on a CentOS 6.4 Linux machine. Still no luck. Supposedly, the proper USB drivers are built into the kernel as of 6.3 so I shouldn't have to worry about the drivers. Anyways, in /var/log/messages, I see the usb driver detecting something but it eventually says "device descriptor read/64, error -110" in the messages file. And no USB device shows up in /dev. 

 

Anyone have any ideas? It seems like the board isn't booting all the way up. Do I need to change some jumpers from the factory setup? All documentation I've seen says to use factory settings. 

 

Here are the main ones I have: 

CLKSEL0 - right 

CLKSEL1 - right 

BOOTSEL0 - left 

BOOTSEL1 - right 

BOOTSEL2 - left
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
81 Views

Well, the good news is I got it all to work - both the usb and ethernet. The bad news is that now I feel like an idiot. Make sure you plug into the proper usb port. There are 3 ports, not just one. 

 

The only thing that doesn't quite work right is DHCP. It doesn't get it's IP at boot up. I have log in and run "ifup eth0", which causes the interface to come up and get an IP and DNS, etc.
Altera_Forum
Honored Contributor I
81 Views

Hi , what is "Wireshark" is it software tool or hardware debugger ?

Altera_Forum
Honored Contributor I
81 Views

Wireshark is the successor to Ethereal, which is a network traffic analyzer. You can run it on your host computer and Wireshark will display all ethernet packets that make it to the computer's NIC. Very useful tool for debug.

Reply