FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5281 Discussions

DE1 SD card and music player demo problem

Altera_Forum
Honored Contributor II
839 Views

Hi everyone, 

 

I tried to run the demo provided on the CD (DE1_SD_Card_Audio) and if it is working. I programmed the DE1_SD_Card_Audio.sof.  

 

My problem is when the DE1 is programmed with the demo .sof file and with the SD card properly formatted with FAT16, the audio file on it and the card itself properly inserted the only sound from the headphones is a flash of static if the pushbutton KEY[0] is pressed. 

 

i have searched thru the forum for help and i came across this thread: 

 

http://www.alteraforum.com/forum/showthread.php?t=547 

 

Solution suggested: 

 

 

--- Quote Start ---  

It is due to the fact that Pin w20 has more than one function. It can also be used as a programming pin. 

 

Here is how to fix it. 

 

go to assignments, device, device&pin settings , dual purpose pins... change the nCEO to be a regular I/O pin.. 

 

This will fix your problem. 

--- Quote End ---  

 

 

 

However, it still doesn't solve my problem after compiled the code. My nCEO is already set as a regular I/O pin. 

 

Thank you in advance for any help.
0 Kudos
0 Replies
Reply