Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
290 Views

Flash Loader IP not loaded on device 1?

Hello,

 

I have a Cyclone IV based FPGA board (LimeSDR-PCIe v1.3) I am trying to flash FPGA FW but in Quartus I always get this error. "Flash loader IP not loaded on device 1" see log below.

 

/altera_lite/15.1/quartus/bin$ quartus_pgm -m jtag -o "ipv;./LimeSDR-PCIE_lms7_trx_HW_1.3.jic"

Info: *******************************************************************

Info: Running Quartus Prime Programmer

  Info: Version 15.1.2 Build 193 02/01/2016 SJ Lite Edition

  Info: Copyright (C) 1991-2016 Altera Corporation. All rights reserved.

  Info: Your use of Altera Corporation's design tools, logic functions 

  Info: and other software and tools, and its AMPP partner logic 

  Info: functions, and any output files from any of the foregoing 

  Info: (including device programming or simulation files), and any 

  Info: associated documentation or information are expressly subject 

  Info: to the terms and conditions of the Altera Program License 

  Info: Subscription Agreement, the Altera Quartus Prime License Agreement,

  Info: the Altera MegaCore Function License Agreement, or other 

  Info: applicable license agreement, including, without limitation, 

  Info: that your use is for the sole purpose of programming logic 

  Info: devices manufactured by Altera and sold by Altera or its 

  Info: authorized distributors. Please refer to the applicable 

  Info: agreement for further details.

  Info: Processing started: Wed Apr 22 13:06:06 2020

Info: Command: quartus_pgm -m jtag -o ipv;./LimeSDR-PCIE_lms7_trx_HW_1.3.jic

Info (213045): Using programming cable "USB-Blaster [1-2]"

Info (213011): Using programming file ./LimeSDR-PCIE_lms7_trx_HW_1.3.jic with checksum 0x7273C3BF for device EP4CGX30CF23@1

Info (209060): Started Programmer operation at Wed Apr 22 13:06:07 2020

Info (209016): Configuring device index 1

Info (209017): Device 1 contains JTAG ID code 0x028230DD

Info (209007): Configuration succeeded -- 1 device(s) configured

Error (209062): Flash Loader IP not loaded on device 1

Error (209012): Operation failed

Info (209061): Ended Programmer operation at Wed Apr 22 13:06:11 2020

Error: Quartus Prime Programmer was unsuccessful. 2 errors, 0 warnings

  Error: Peak virtual memory: 411 megabytes

  Error: Processing ended: Wed Apr 22 13:06:11 2020

  Error: Elapsed time: 00:00:05

  Error: Total CPU time (on all processors): 00:00:01

 

Can anyone guide me what the issue could be, Is there some file missing?

The repo is available here: https://github.com/myriadrf/LimeSDR-PCIe_GW

 

I am using Quartus Lite 15.1.2 Build 193.

 

Thanks.

0 Kudos
4 Replies
Highlighted
198 Views

Hi,

 

Thank you for contacting Intel community.

 

You can try to use following solution:

 

  1. https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/soluti...

2. ID:209062 Flash Loader IP not loaded on device <number> 

CAUSE: You tried to program one or more serial or parallel configuration devices, using a Programmer Object File (.pof) (../../reference/glossary/def_pof.htm). However, the specified device was not configured with the Flash Loader IP.

ACTION: Make sure the Flash Loader IP is loaded on the device, and make sure the POF can communicate with the device, for example, make sure the communications cable is properly attached and the device has power.

 

Let me know if you need further information.

 

Thank you.

 

Regards,

Aiman

 

0 Kudos
Highlighted
Beginner
198 Views

Hi Aiman,

 

Thank you for your reply. Itrei I have two such development boards and the issue always happens on one of those and occasionally on the other. I do the following steps for programming.

 

  1. Open programmer in Quartus.
  2. Select USB-Blaster in Hardware tab
  3. Select Auto Detect.
  4. Select change file and choose the corresponding myfile.jic
  5. New design opens up. I check both boxes on Program/Configure (For FPGA and EPCS64 flash).
  6. Click on Start.
  7. The procedure halts at 21% with the message "Flash loader IP not loaded on device 1"

 

With the above procedure after checking the Program/configure box a Factory default SFL file is selected to be loaded. Is there any other extra step I should do?

Following are the screen shots.

20200422_100415.jpg

20200422_100349.jpg

0 Kudos
Highlighted
198 Views

Hi,

Have you tried with USB Blaster II?

 

Thank you.

 

Regards,

Aiman

0 Kudos
Highlighted
198 Views

Hi,

 

Is there any update on this request? Else, I will continue to close this case

 

Thank you.

 

Regards,

Aiman

0 Kudos