FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5286 Discussions

Issue in generating the Start of Packet, End of Packet and Empty for the Avalon FIFO Memory Intel FP

Sudhirkv
Novice
357 Views

Hi All,

I am facing the issue while generating the SOP(Start Of Packet), EOP(End Of Packet) and Empty for the Avalon FIFO Memory Intel FPGA IP. 

Description: Input is applied at the Avalon MM port, I could able to get the output at the stream port. Along with the output  SOP, EOP and Empty should be generated but these signals are not getting generated from the Avalon stream port at the output. 

Wave form screen shot is attached for the reference purpose. Please help me with this issue.

Thanks in Advance... 

0 Kudos
3 Replies
sstrell
Honored Contributor III
336 Views

The ready signal is active, so it's not the downstream component causing the issue.  Can you post your IP parameter settings?  Maybe you have something configured incorrectly for packetized streaming output.

Sudhirkv
Novice
322 Views

Hi, 

I have uploaded the project to this ticket.

 

Regards,

Sudhir

dan123
Beginner
204 Views

I am also facing this issue and I have set the FIFO parameters correctly. Any idea on this?

Is this issue resolved?

Reply