FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5345 Discussions

SignalTap Logic Analyzer waveform display

BMart12
New Contributor I
409 Views

Hello,

I am using the SignalTap II logic analyzer on Quartus Prime Version : 18.1.1 Build 646 04/11/2019 SJ Standard Edition.  I am tracing logic in the Cyclone V SOC.  Sometimes whan I run analysis the waveform display presents blue left and right arrows which allow me to locate the next edge in the trace.  Sometimes I do not get the arrows.  Please le me know what I need to do to activate the arrows.  I provide two screen shots, with arrows and without arrows.

 

Thank you

0 Kudos
1 Solution
BMart12
New Contributor I
383 Views

I made a new stp file.  Prior to running an analysis I punched in numbers starting at 0 for the aliases.  I use the signaltap text file to lift the signal names when I record the results of the analysis.  When I ran the analysis the arrows magically appeared.  I did not even add time bars.

I had been reusing the old stp file.  I wonder if reusing the stp too many times confuses SignalTap.  Should I be using a new stp file each time I want to add signals?

View solution in original post

4 Replies
sstrell
Honored Contributor III
399 Views

I don't see the arrows in either of your screenshots, but normally you have to select a signal to use the arrows since they are used to jump to the next signal edge for a particular signal.   I think you also have to have the master time bar (solid vertical black line) and a reference time bar (dashed line) enabled.

BMart12
New Contributor I
395 Views

Thank you for replying.  I learned from this exchange that the export to BMP function does not show the arrows.  I provide a screen shot.  I was fiddling with the master and reference time bars trying to enable the arrows.  Per your reply, I tried selecting a signal but was unable to activate the arrows.

sstrell
Honored Contributor III
385 Views

So you're saying you see the Value column but no arrows above it?

I click where it says "Click to insert a time bar" and the Value column and the arrows appear.

BMart12
New Contributor I
384 Views

I made a new stp file.  Prior to running an analysis I punched in numbers starting at 0 for the aliases.  I use the signaltap text file to lift the signal names when I record the results of the analysis.  When I ran the analysis the arrows magically appeared.  I did not even add time bars.

I had been reusing the old stp file.  I wonder if reusing the stp too many times confuses SignalTap.  Should I be using a new stp file each time I want to add signals?

Reply