Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SP1
Beginner
180 Views

pin assignments to GPIO of Cyclone II

Dear Sir/Ma'am got the starter kit of Cyclone II :

 
I am facing a problem regarding pin assignments. I tried to assign an on-board switch to an on-board LED.
Similarly, I assigned a switch to external pins: GPIO 0 or GPIO 1 plug, but nothing is working ---means I cannot assign any IO's to external peripherals through these plugs. 
 
 INTERNAL : Switch ------- Internal ------ LED  works fine    LED lights if switch on and vice - versa 
EXTERNAL : Switch ------- Internal -------LED  doesn't work   (Switch  is connected to 3.3 Vdc from the board)     
 
       3.3V ____/ ________............._____LED.             
 
PLEASE can you help me. Can not find any reference to this problem  in manual ---- Pin assignment as per the instruction.
 
With kind regards,
Sayali Pawar
Electronics Engineer
MIT, Australia
0 Kudos
3 Replies
AminT_Intel
Employee
169 Views

Hello,

Did you configure your device according to the guideline on this document? 

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/cyc2/cyc2_cii5v1.pdf (page 78)

SP1
Beginner
156 Views

I assigned the pins same as we do for internal ones. I am using Version 7 of QUartus II

AminT_Intel
Employee
150 Views

Have you tried assigning the pins according to IO standards from the link I have provided? Have you tried configure this the same settings to other Cyclone II device? 

Reply