Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
20351 Discussions

Arc A750 blank screen

Dan-H
Beginner
899 Views
Just installed my new A750 and having difficulty to get it to register. Won’t even show bios on boot up never mind getting to windows splash screen.

Tried a few things to date:
1) It works in my sons pc who is running purely a AMD with integrated graphics.
2) swapped back out for my old graphics card and this has consistently worked.
3) tried different power cables - no luck
4) tried reducing to one stick of ram - no luck
5) reset CMOS - no luck
6) updated bios to latest firmware - no luck
7) tried removing existing nvidia files via DDU - no luck
😎 changed to more standard resolution - no luck

It’s running on a Gigabyte motherboard. My sons is gigabyte too.

My processor unfortunately doesn’t have onboard graphics.

Any help much appreciated,

Regards


Daniel
0 Kudos
7 Replies
Jean_Intel
Moderator
861 Views

Hello Dan-H,

 

Thank you for posting on the Intel️® communities. We are sorry to hear that you are experiencing issues with your new A750.

 

In order to have a better understanding of your issue, please provide me with the following:

  • Is the card working properly on your son's system? Is it being registered on the BIOS?
  • Provide us with your system information:
    • Motherboard
    • CPU
    • Operating System version and build

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Dan-H
Beginner
844 Views

Hi Jean,

 

Motherboard:

Gigabyte B550I AORUS PRO AX
Just updated BIOS to F17b
 
CPU:
AMD Ryzen 9 5900X
 
Operating system: 
Microsoft Windows 10 Pro (64-bit)
Version (Build) 21H2 (10.0.19044)
 
Hope this helps,
 
Regards
 
 
Daniel
 
0 Kudos
Jean_Intel
Moderator
835 Views

Hello Dan-H,

 

Thanks for the information you provided.

 

Since you are running an AMD CPU system, make sure to disable the SVM feature from BIOS settings. If you are not familiar with navigating through BIOS settings, please contact the motherboard manufacturer.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Dan-H
Beginner
815 Views
Hi Jean,

This already looks to be disabled in BIOS.

I’d also changed ‘CSM Support’ to enabled which I’d read elsewhere.

Still to no avail.

Thanks


Daniel
0 Kudos
Jean_Intel
Moderator
799 Views

Hello Dan-H

 

Thanks for the information provided.

 

We will do further research on this matter and post the response on this thread once available.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Moderator
779 Views

Hello Dan-H,

 

Thank you for waiting for a response.

 

Since the card works on another system, the issue doesn't seem to the related to the Arc card. We advise you to contact Gigabyte support to check the compatibility of your motherboard.

 

If you prefer, you can still contact us directly through live support to initiate the RMA process (you cannot do this through the forums). Here are pages where you can look up contact information, including local/country phone numbers, by geography:

 

U.S. and Canada: Intel Customer Support

Europe, Middle East, and Africa: Intel Customer Support EMEA 

Asia-Pacific: Intel Customer Support APAC 

Latin America: Intel Customer Support LAR  

 

Best regards, 

Jean O. 

Intel Customer Support Technician


0 Kudos
Jean_Intel
Moderator
719 Views

Hello Dan-H,

 

We hope you are doing fine.

 

We have not heard back from you. So we will close this thread. If you need any additional information, submit a new question, as this thread will no longer be monitored.

 

Best regards.

Jean O. 

Intel Customer Support Technician.


0 Kudos
Reply