Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
18306 Discussions

Intel UHD driver for N5105 processor crash Windows 10 Pro 21H2 system

Igor2
Beginner
629 Views

Hi,

 

I have tried to install fresh Windows 10 Pro (21H2) operating system on Celeron N5105 based platform. However as soon as video driver for Intel UHD graphics is installed the whole system stops responding in very few seconds. It suddenly redraws entire display screen with flickering colour changing garbage together with few small rectangular clusters scattered over the screen also changing their pixels colour. The only way out is to power off the system by holding power button. If booted up then in normal mode then it goes into the same state in few seconds while just showing login screen. To regain any stable state I had to boot it into safe mode and disable Intel(R) UHD Graphics Display adapter in Device Manager. I have first tried vendor supplied video driver version 27.20.100.8836 but the problem remains exactly the same if newer driver version 30.0.101.1069 is installed by Windows update or if I use the latest driver 30.0.101.1191 from Intel web site directly. I have also tried to install drivers before or after updating Windows with all patches but having the same outcome.

 

Please find system configuration details attached.

 

I would appreciate any help to resolve the issue.

Labels (1)
0 Kudos
2 Replies
n_scott_pearson
Super User Retired Employee
618 Views

Have you checked for a BIOS update for your motherboard?

Igor2
Beginner
606 Views

Yes, I have checked that BIOS is the latest. However this is a bit difficult to be certain.

On Gigabyte web site here

 

https://www.gigabyte.com/Mini-PcBarebone/GB-BMCE-5105-rev-10/support#support-dl-bios

 

it shows that first version 1.0 was released on 2021/05/05 described as "BRIX Jasper Lake series BIOS initial release" and then later on version F4 was released on 2021/07/29 described as "BIOS Fixed : Random Boot Failures issus"

 

System scan report shows in computer section that

BIOS Version/Date:"American Megatrends International, LLC. F4 , 06/05/2021 12:00 AM"

 

and Motherboard section shows

BIOS:"F4, GBT    - 1072009"

 

so version seems to be F4 matching the latest but time stamp looks a bit suspicious

 

Do you think BIOS can actually cause such strange behaviour? Until UHD driver is enabled all the rest looks pretty stable  

Reply