Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20845 Discussions

NUC 10i5fnh graphic driver not working


Hi @all


i am really frustrated. 

I have a Intel NUC 7i3BNH with Windows 10 1909 on a LG 34wk95u display.

Everthing works fine with a single thunderbolt cabel and a resolution of 5120x2160 on latest graphic drivers.


Now i bought a new Intel NUC 10i5fnh and nothing works.

Setting up windows 10 x64 20H2  without internet (from boot stick) i can see windows desktop with 800x600 (connected with thunderbold cabel)

When i install any Intel graphic driver (no matter wheather from windows update or Intel site)

my display starts to flicker. Screen gets dark and every 3 to 5 seconds i can see the desktop for milliseconds. 

When i switch to hdmi Port everything is fine, but resolution ist not 5120x2160 but only 3840x2160. 

@intel:What are you doing with your drivers?

I read a lot of arcticles on intel community, tried many different drivers, but i couldn't get any answer to that problem.

Help me, otherwise this is my last NUC.

0 Kudos
6 Replies

Here are 2 system data sheets. one is the nuc7i3 which is working fine and the other one is the 10i5 which is not working.

0 Kudos
Super User

Hi @geierlein 

This is link for Intel Download site for your NUC.

Please download and install manually the Chipset Software and Management Engine Consumer Driver. Reboot your NUC.  Disconnect the internet and uninstall the currently installed driver. Reboot your NUC again. I would also update the HDMI Firmware as well.

Now reinstall the Intel Graphics Driver. BTW, as you can see the Version: is the latest version validate by Intel for your NUC. However, in my opinion the latest  Version should be O.K. as well. 

Reconnect the internet and reboot your NUC. 



0 Kudos

thank you for your response.

i will try that.

By the way, i found out how to make 5120x2160 over hdmi possible.

Just add the on the rgistry key [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000] the DWORD 32 Entry "Enable5kModeSupport" with a value of "1" and reboot. Now you can set at Intel Graphic Control Center custom resolution of 5120x2160.
Works perfectly for me, but didn't solve my thunderbold problem.

0 Kudos

Hi geierlein,

I am really sorry to hear that you are frustrated with one of our products.
The NUC10i5FNH is designed to support a maximum resolution of 4096 x 2160 @ 60hz, 24bpp on the HDMI port, and a maximum resolution of 4096 x 2304 @60 Hz, 24 bpp on the Display Port via the USB Type-C. Refer to the Product Technical Specification if you need further information.

5120 x 2160 is not officially supported on either port at this moment, you may modify the registry keys to allow 5k resolution on the HDMI port but again this is not officially supported or recommended and for the Thunderbolt port it may need two display ports (two cables) to function properly and again this is not supported based on the product specification.

I hope this helps.



Ronny G


By the way, what works on a previous NUC generation or in a similar model may not work for others, this is why we stick to the Product Technical Specification.

0 Kudos


your solution worked for me but only until next reboot.
After reboot old problem came back.

but now i know that the problem is not a hardware problem.

I really would like to talk to Intel Driver Developer and ask how many idiots developed such a bul**bleep**.

There are so many Display who need 5k support and tunderbold should always work with every driver.

A nuc without clean and working drivers is a nuc that nobody needs.

0 Kudos
Super User

Hi @geierlein 

1. Is your Thunderbolt driver updated? If not, pleas download the driver zip file and unzip it in your NUC. Read the Installation Instructions.txt how to install manually the inf files. 

2. BTW, also there is a new version for the HDMI firmware.

3. Is your BIOS updated to version 0047?




0 Kudos