Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
17661 Discussions

can't run apps that require opengl 2.0

Abir
Beginner
326 Views

am using an intel pentium cpu g620 2.6ghz,I want to run apps that requires opengl 2.0 or greater,it says that the processor does support opengl higher than version 2.0,though none of those apps run in my computer,how do I fix this issue?I did download the necessary drivers from the intel.still no solution

0 Kudos
1 Reply
AlHill
Super User
315 Views

Your processor is using the Microsoft generic graphics driver, which lacks features and performance.  There is no Windows 10 driver from Intel.

 

How to fix?  If you are a desktop, get a nvidia graphics card.   If you are a laptop, there is nothing you can do.

 

In all cases, for this 10-year old processor, replace the hardware with a new or newer system that has an 8th gen processor or later.

 

Doc (not an Intel employee or contractor)
[Windows 11 is the new Vista]

Reply