Community
cancel
Showing results for 
Search instead for 
Did you mean: 
224 Views

why my graphics driver not updating

 
0 Kudos
3 Replies
AlHill
Super User
33 Views

Well, that is hard to say without more information.

 

What is the model number of your processor?

What is the model number of your laptop or motherboard?

What version of Windows 10? 1909?

If you are a laptop, do you have dual graphics?

If you are a laptop, are you trying to use the generic Intel graphics driver?

 

Doc

 

Lewis-H
New Contributor I
33 Views

I have had this issue with Windows 10 only but it may be a fix on all versions. Just follow the same steps and get the appropriate driver for model and OS version.

I will try to explain the whole situation and be as concise as possible as I put a ton of work into getting my discrete card to actually work.

 

A note here - when I bought this PC it had Win 8 and ran great. Updates applied from GeForce experience worked fine, no issues. When I updated to Win 10 it still worked fine for a time, then it all went wrong...fast. I had on 2 separate occasions my GTX 760m totally unusable, found a temporary fix and now have it running stably in 90% of my apps.

 

The first fix that worked was simply updating BIOS to 204. All was fine until win 10 automatic updates intalled a new driver and the GTX 760m was no longer usable.

 

With the N56JR these just seems to be very little ongoing support for the GPU. I contacted support and was told that the release drivers work and that I should only use those. This is upsetting because of all of the builds that have been released since, (especially as I have used those builds in windows 8 with no problem). What I have found to work is;

 

1. Get the most recent BIOS for the unit and flash it. If you don't know how to do this make sure you find out or get a friend with experience, you can make things a lot worse for yourself if you mess this up.

 

2. This is likely most important - Disable windows update ability to update additional devices. Updates and security in sttings, then advanced and look for the checkbox - "Get me updates for......" - uncheck that box.

 

This card is just not liking using any of the newer drivers up to Sep 2015 that have been released for win 10. You have to use the initial release.....hopefully this will be looked at again by the people who build the driver sets.

 

2. Delete all of your Nvidia drivers and associated software. Dont bother re-installing at this point. Just use the Intel graphics until we get there. This requires a restart here I think.

 

3. Go to Asus support and get the origianl drivers for your Intel graphics, install those. Restart PC as prompted.

 

4. At this point you can get the drivers for your Geforce card - get the original Drivers from the asus support page for your model and OS. Install these, including the Geforce experience software, you will need this software and the control panel to decide which applications use the Geforce card vs the intel graphics.

Make sure you disable automatic update to your Nvidia drivers on Geforce experience.

 

At this point you will have the original drivers and it should work. I have found that certain applications still have hangups. I will come back and elaborate on any additional tweaks that improve on this.

 

Hope this works for you all.

 

--

Lewis

AlHill
Super User
33 Views

@Lewis-H​ Do you not think it would be appropriate to get the user's configuration BEFORE posting a solution? Also, we do not do nvidia (or amd) here.

 

Doc

 

Reply