Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1711 Discussions

Issue with fan control and fan speed metric

alcompilor
Beginner
1,301 Views

Hello

I'm having a problem with the fans of my Intel Arc A750 (Limited Edition).

Here is the problem:

  • Firstly, there is no fan speed metric displayed in the Intel Arc Control Software, preventing the observation of RPM. I also attempted to download GPU-Z to check for fan speed metrics, but it failed to detect any fan speed sensors.

  • Upon the booting of my operating system and logging into my user account, the fans appear to operate at normal/idle speed. When I put a load on my GPU, such as playing a game, the fans start spinning at max speed (or at least a high speed). This behavior is entirely normal; however, when I exit the game and attempt to return my system to a normal load, the GPU fans do not adjust to a lower speed. They continue running at max speed until I restart my computer. (This is happening in both Automatic mode and Fan curve mode, no difference).

  • When attempting to control my fans using the Intel Arc Control Software, changes are not applied unless they involve setting the fan speed to high speeds. For example, if I choose "Fixed fan target" mode to control my fans and set it to 90%, the fans will adjust to that speed. However, when I try to decrease it to a lower percentage, like 30%, the fans do not adjust to that lower speed at all.

In summary, something seems to be amiss with fan control and fan sensors. I tried a lot of things, and I don't know what is causing this issue. I also tried to enable the option "Apply settings on system boot" in Intel Arc Control Software but no luck.

I'm running dualboot (Windows 11 and Fedora KDE) and the problem exists in both systems so I don't think it's OS related to begin with.

---------

Some info:
- Motherboard: GIGABYTE Z690 AORUS ELITE DDR4 

- Intel Arc Driver: 31.0.101.5084 (WHQL)
- DDU in Safe mode: Yes, I used it to clean Nvidia, AMD and Intel drivers and then exited Safe mode to install latest Intel Arc Driver 31.0.101.5084 (WHQL).
- Resizable BAR: Enabled

- Native ASPM: Enabled

- How to reproduce the issue? It's a persisting issue in my case. I don't know how it can be reproduced in another environment.

----

SSU attached.
Hope there is a solution for this issue. 

Labels (1)
0 Kudos
1 Solution
alcompilor
Beginner
1,251 Views

After hours of testing, I figured out that I had a defective PSU cable which limited my GPU's ability to control fans. After replacing it fans stats started showing and fan control worked as it should.

This discussion can be closed

View solution in original post

0 Kudos
1 Reply
alcompilor
Beginner
1,252 Views

After hours of testing, I figured out that I had a defective PSU cable which limited my GPU's ability to control fans. After replacing it fans stats started showing and fan control worked as it should.

This discussion can be closed

0 Kudos
Reply