Intel® Distribution of OpenVINO™ Toolkit
Community assistance about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all aspects of computer vision-related on Intel® platforms.

DL Workbench 2021.4 Issue

resh
Beginner
1,609 Views

While doing INT8 Calibration -

I get this error -

The -result-archive argument is not set. The default value /home/workbench/.workbench/models/1/15/job_artifacts/artifact.tar.gz will be used.

[setupvars.sh] OpenVINO environment initialized

0%| |00:00 0%| |00:00 0%| |00:00/home/workbench/.workbench/models/1/15/scripts/job.sh: line 66: 3173 Killed pot --direct-dump --progress-bar --output-dir ${ARTIFACTS_PATH} --config ${JOB_BUNDLE_PATH}/scripts/int8_calibration.conf.json

 

What's gone wrong here?

0 Kudos
7 Replies
Marat
Employee
1,581 Views

Hi @resh ,

Thanks for your question.

What OS are you using? According to this error log, it seems like there is not enough RAM allocated to the docker container. By default there is 2GB RAM allocated to Docker in Windows or MacOS and it is not enough to calibrate some big topologies. Try to increase allocated RAM in Docker preferences and calibrate again.

 

Regards,

Marat.

0 Kudos
resh
Beginner
1,576 Views

Hi @Marat !

 

I am on Ubuntu 18.0 LTS - Linux

0 Kudos
Alexander_D_Intel1
1,543 Views

@resh wrote:

Hi @Marat !

 

I am on Ubuntu 18.0 LTS - Linux


Hi @resh,

 

Could you tell me more about your hardware setup? How much RAM does your machine have? You can share the full command output or just the part of it explaining the RAM quantity:

free -m

Also, can you share settings of the Docker on your machine? Running with sudo if required:

docker info

Also, INT8 calibration is RAM demanding because of the model, different models require a different amount of RAM for Calibration. So, can you tell me what is your model, its architecture? Is it from Open Model Zoo?

 

--

Alexander Demidovskij

0 Kudos
resh
Beginner
1,501 Views

Hi @Alexander_D_Intel1 

 

The screenshots for aforementioned case are attached below-

free_m.pngdocker_info.png

0 Kudos
Alexander_D_Intel1
1,457 Views

@resh thank you for providing all the information. From the screenshots that you have provided, I can see that your Docker server is taking all the available RAM (8Gb). So, now the only question is about the model. Most likely it requires more RAM to be calibrated. To be absolutely sure, can you tell me more about the model? Its architecture? Is it from Open Model Zoo?

 

Usually, we recommend users calibrate models on machines with 16 GB RAM. Of course, there are cases when calibration is possible even with 8 GB, but there are even models that require 32 GB and much more.

 

--

Demidovskij Alexander

0 Kudos
Syamimi_Intel
Moderator
1,545 Views

Hi Reshu Singh,

On Linux hosts, if the kernel detects that there is not enough memory to perform system functions, it will starts killing processes to free up memory. Thus, please try to increase allocated RAM in Docker preferences and calibrate again.

 

 

Regards,

Syamimi


0 Kudos
Syamimi_Intel
Moderator
1,426 Views

Hi Reshu Singh,

This thread will no longer be monitored since we have provided a solution. If you need any additional information from Intel, please submit a new question.



Regards,

Syamimi


0 Kudos
Reply