Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
856 Discussions

Cannot install/run CodeBuilder on Eclipse

okramer
New Contributor I
309 Views

I recently downloaded AOCL-pro-19.3.0.222-linux.tar and ran the install script. According to the instructions here, there should have been an eclipse plugin file in $INTELFPGAOCLSDKROOT/eclipse-pug-in. But instead, I found there was another similarly named env var defined (INTELOPENCLSDKROOT) pointing to /opt/intel/system_studio_2019/opencl/SDK, where I did find that plugin.

I followed the directions in the programming guide (link above) and placed the CodeBuilder_6.4.0.jar in my eclipse/dropins folder. After a restart of eclipse, I don't see any reference to it in the Windows->Preferences, and I don't see any evidence that it was picked up.

I'm running Eclipse 4.13 on Ubuntu 16.04.

One data point: if I run eclipse on the command line with "-console" option, and then do "lb" (list bundles), I see

595|Installed | 4|CodeBuilder (6.4.0)|6.4.0

So something is happening. What am I supposed to see or open to access the functionality of that plugin?

0 Kudos
0 Replies
Reply