Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.

Modelsim Licensing on Ubuntu 18.04

NPani2
Beginner
1,062 Views

I have an Academic License for Intel Quartus Prime Standard Edition and Modelsim Intel edition. The license is not a floating license, but rather a single PC license.

 

I am able to run Quartus, compile the design and program the design to the FPGA,

 

However the Pro Version of Modelsim does not launch. I have installed the 32 bit libraries and made appropriate changes to the vsim script in the bin directory, but when I try to execute the script after changes I get this error

 

"Unable to find the license file. It appears that your license file environment variable (e.g., LM_LICENSE_FILE) is not set correctly.

Unable to checkout a license. Vsim is closing.

** Fatal: Invalid license environment. Application closing."

 

Anybody knows how to fix this licensing issue.

 

 

0 Kudos
3 Replies
AR_A_Intel
Employee
879 Views

Hello

 

Welcome to INTEL forum. May I know Quartus version you use?

0 Kudos
NPani2
Beginner
879 Views

It is Quartys Prime Standard edition 18.1 . The license file generated is the .dat file fixed to a single computer. I am using the Terasic DE5 Net FPGA board. I am able to synthesize and program the design, but not able to run Modelsim due to the following issues.

0 Kudos
AR_A_Intel
Employee
879 Views

Could you help check and upgrade the client PC to newest version of alterad and Modelsim daemon v11.16.1 & 11.13.1.2 and try it.

The daemons can be downloaded from the following link:

https://www.intel.com/content/www/us/en/programmable/support/support-resources/download/licensing/daemons.html    

 

0 Kudos
Reply