Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
808 Discussions

Quartus 19.4 in both linux and windows, fail to open ALTMEMPHY wizard.

BHerr6
Novice
337 Views

I've been trying to use the ALTMEMPHY wizard, but it fails to open. I tried on Arch Linux and on Windows 10. Both versions fail to open the ALTMEMPHY wizard, but they show different behavior.

 

In Arch Linux, Quartus fails to find the path of the wizard. In Windows 10, Quartus won't even show any error, it just doesn't open any wizard, just shows a message "Loading MegaWizard", and never opens nothing.

0 Kudos
3 Replies
RichardTanSY_Intel
262 Views

The IP is only supported for certain devices thus not supported for all the devices in Quartus Pro 19.4. Also, the ALTMEMPHY-based memory controllers were removed from the IP Base Suite and Embedded Suite (EMIF) beginning with the v14.1 release.

Reference: https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug_ddr3_sdram.pdf#page=3

 

You can refer to this page for further information on External Memory Interfaces IP information for Intel Agilex, Stratix 10, Arria 10, and Cyclone 10 devices.

https://www.intel.com/content/www/us/en/programmable/support/support-resources/support-centers/exter...

 

Or you can refer to "Memory Interface and Controllers" in the IP catalog for the currently supported IP.

 

p.s. Don’t forget to Reply, and Select the Best Solution. :)

BHerr6
Novice
262 Views

So, what should I use to drive DDR2 memory from an EP4CE115F23 FPGA? I can't use UniPHY, its not supported.

BHerr6
Novice
262 Views

I solved the issue, I just had to install Quartus 14.0 and merged the IP folders.

 

I installed the Quartus 14.0 in

~/intelFPGA_lite/14.0

After the Quartus 14.0 installation was done, I merged the IP folders

rsync -a ~/intelFPGA_lite/14.0/ip ~/intelFPGA_lite/19.1/ip   rsync -a ~/intelFPGA_lite/14.0/quartus/common/ip/altera/ ~/intelFPGA_lite/19.1/quartus/common/ip/altera/

Then I opened Quartus 19.1, and now ALTMEMPHY IP was installed.

 

Reply