Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1082 Discussions

DE0-NANO Quartus Lite 19.1 NIOS II Project error

ABerg28
Beginner
398 Views

Hello,

          I'm dead in the water now. I've been following a YouTube tutorial to build a simple adder program to run on the NIOS II in a Cyclone IV on a DE0-NANO board.

https://www.youtube.com/watch?v=fjIpzcCmZyY

The version of Quartus II he was using was back several versions but it was close enough I could follow it. I was able to get the NIOS II soft core built and downloaded to the board. The problems began when I tried to use the NIOS II - Eclipse software development environment. Do the following steps:

1- Select NEW

2- Select NIOS II Application and BSP from Template

3- Entered the SOPC  Information File Name: adder.sopcinfo

4- Entered project name: nios_adder_temp

5- Selected "NEXT"

6- New window popped up. Chose: Create a new BSP based on the application project template

7- Entered Project name:nios_adder_temp_bsp

8- Chose "use default location"

9- Clicked finish

10- Get error message: Failed to execute wsl dos2unix create-this-bsp; ./create-this-bsp --cpu-name nios_2processor --no-make

In the Eclipse message window I get this:

Executing: wsl dos2unix create-this-bsp; ./create-this-bsp --cpu-name nios2_processor --no-make (D:\UW-Bothell\FPGA-Design\software\nios_adder_temp_bsp)
'wsl' is not recognized as an internal or external command,
operable program or batch file.

This is where I'm stuck. The YouTube tutorial goes on its merry way. I've watch the tutorial too many times and I'm doing exactly what the tutorial does, but I get stuck here. The Terasic documents or tutorials are too old and are too many Quartus revisons back to be of any use.

Any suggestions would be most appreciated.

 

Arnie

7-

0 Kudos
4 Replies
EricMunYew_C_Intel
Moderator
353 Views

can you check you have WSL1 installed.


ABerg28
Beginner
349 Views

The solution is very convoluted. The problem is that with Quartus II version 19.1 and up, WSL was not included. There is a patch, but the patch is too onerous. I would have to install Ubuntu Linux and do some more stuff. I was advised that the best solution was to go back to earlier Quartus II versions before 19.1.

I installed 17.1 and it now works fine.

I think it would be nice if Intel asked an intern to create a support matrix of Quartus II versions and for each version, list what has improved or changed and what has been removed. And it gets worse. In the download page, Intel suggests that you should always get the latest version, but the page doesn't tell you what the consequences will be if you do.

Simple example: All the tutorials discuss how to use Qsys. OK, I'm following along with a tutorial. Where's Qsys? Its not there. Searched the web, nothing. Finally, as a guess, I tried Project Builder. Aha! They renamed Qsys to Project Builder, but apparently kept it a secret. Would it have hurt to put "Project Builder (Qsys)" on the drop down menu?

Thanks for your input.

EricMunYew_C_Intel
Moderator
330 Views

Platform Designer is a newer tool and it has replaced Qsys.


EricMunYew_C_Intel
Moderator
328 Views

You can install below manually.

 

1. install WSL for windows

i. https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/nios2/n2sw_nii5v2gen2.pd... (chapter 2.1)

 Note: Windows 10 build version 16215.0 or higher is the recommended operating system version.

ii. After installation has successfully completed, launch Ubuntu 18.04.

iii. Install additional distro packages required for Nios II EDS using the following commands:

 a. sudo apt install wsl

 b. sudo apt install dos2unix

 c. sudo apt install make

 

before"sudo apt install wsl"

run:

sudo apt-get update

 

2. install nios2 eclipse folder

https://www.intel.com/content/altera-www/global/en_us/index/support/support-resources/knowledge-base...


Post Time07 September 



Reply