Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

De2_nios_device_led

Altera_Forum
Honored Contributor II
789 Views

Hello everyone, 

 

I'm trying to get DE2_NIOS_DEVICE_LED demonstration working. The problem is when I try to install the d12test.inf driver, windows says "the wizard could not find a better match for your hardware .... " and the Philips smart evaluation board is not installed. 

------------------- 

Step 9 of README.txt 

9) Run the project on the board. (Run menu) 

 

I choose "run" from the upper toolbar. Then I choose "Nios 2 Hardware", then "new configuration". I select project "hello_led_0". 

JTAG cable: automatic 

JTAG device: automatic 

Nios 2 Terminal: jtag_uart_0 

 

At this point the only wires connected to the DE2 board are: "blaster" and "DC 9V". 

 

I click "run" from the nios 2 window. 

 

From the terminal: 

 

nios2-terminal: connected to hardware target using JTAG UART on cable 

nios2-terminal: "USB-Blaster [USB-0]", device 1, instance 0 

nios2-terminal: (Use the IDE stop button or Ctrl-C to terminate) 

 

disconnect 

disconnect 

connect_USB 

CONFIG 

CHIP ID =0x3630 

--------------------- 

Step 10 of README.txt 

Now I connect "DEVICE" wire from DE2 to USB on my computer. 

Immediately Windows says "USB Device Not Recognized". 

Nios 2 Terminal outputs this: 

CHIP ID =0x3630 

 

SUSPEND CHANGE  

SUSPEND CHANGE  

BUS RESET 

disconnect 

connect_USB 

CONFIG 

CONFIG 

.. repeat above 7 lines .. 

 

--------------------- 

Step 11 of README.txt 

Since I am on a windows machine, I go to Device Manager. Under "Universal Serial Bus" controllers I see "Unknown Device". This is probably the device that needs drivers since if I disconnect the DEVICE wire, this "unknown device" disappears.  

 

I choose update drivers.. install from specific location... "include this location in your search".. I choose the path which contains d12test.inf (there are actually two folders that contain this, both resulted in the same error). I click next then hardware update wizard says: "the wizard could not find a better match for your hardware". 

 

If I choose "don't search. i will choose the driver to install" and choose d12test.inf .. same error. 

 

If I right click d12test.inf and choose install, nothing happens (philips device is not discovered). 

-------------------------- 

For all cases, the program isp1362dcusb.exe outputs 0x0 no matter how many times I press add. 

 

I'd appreciate all comments and advice. 

Thanks!
0 Kudos
4 Replies
Altera_Forum
Honored Contributor II
102 Views

I meet the same errors. Can anyone prove this problem for me?? Thanks

Altera_Forum
Honored Contributor II
102 Views

Put all the project in C: path ,and try again!

Altera_Forum
Honored Contributor II
102 Views

Dear Friends, 

 

I also had a similar experience.I could not install the ISP1362 river for one month. I solved the problem recently. You try connecting both USB cables( Blaster and Device ) from the begining. Also do this while building the project.after build is complete rmove the USB cable from Device port aand run the C program, once u get a message chip ID XXX, u connect back the Device USB, your DE2 board will be detected by the OS as a new device and it will prompt you to install the driver.  

I hope this will help you... 

 

Regars, 

Mahesh
Altera_Forum
Honored Contributor II
102 Views

Dear Friend, 

 

I solved this problem by using 2 USB cables. Before you programming to DE2 board, you make sure 2 USB cables (USB blaster and USB device) to connect your host computer. It will be solved your problem 

 

Regards 

 

TZ
Reply