Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1082 Discussions

The wlfxxxx files in Modelsim simulation directory

TRoa
Novice
446 Views

Hey guys,

When I run modelsim simulation, in simulation directory some new files are generated which have name format like wlfxxxx (where x is any alphabet).

Why these files are generated and what can I do to stop their generation? Sometimes there accumulates 100s of them.

Thanks in advance.(I am using Intel Modelsim lite)

0 Kudos
5 Replies
RichardTanSY_Intel
435 Views

I believe those files generated when you open a new project .mpf and for each time you run a simulation, it will create a new wlfxxxx file.  I think these files are dataset (I could be wrong) and if you do not need it, you can just delete it.  

I do not see these files generated when running using Nativelink flow or scripted flow which I usually do. Perhaps you can consider that flow. 

Or the community here whom come across this may has a better solution for you.

You may checkout the User Guide below on how to simulate your design.
Quartus Standard (nativelink)
Quartus Pro (scripted flow)

 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

TRoa
Novice
433 Views

@RichardTanSY_Intel 

Thanks for reply. I don't make any project. I just open the Modelsim, write a TCL do file, change to that directory,  run that TCL script, and that's it. That compiles and launches the simulations.

RichardTanSY_Intel
408 Views

I am using Modelsim -Intel FPGA Edition and just like you did, File > Change Directory to where the script file is e.g. example.do, run do example.do and execute the simulation. I am using the example design from the link I provided in my previous response.
In my case, I do not saw the wlfxxxx file generated though, only vsim.wlf is generated. Perhaps you may file a case to the Mentor forum for a solution? 

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

TRoa
Novice
402 Views

@RichardTanSY_Intel Hi,

I got the problem. This is when I save my waveform, it adds few wlfxxx files in the same directory. So yeah, Mentor should address this issue. I call this dirty file pollution by mentor software. 

Thanks anyway.

RichardTanSY_Intel
398 Views

Kindly help to consult the problem with the Mentor. With that, I will now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.

Best Regards,
Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 

Reply