Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26758 Discussions

Getting error message "error #7002: Error in opening the compiled module file. Check INCLUDE paths. [MPI]"



I am an engineering student, working on a project that requires the use of Fortran code (this is to clarify - I'm not a developer or a computing student, so I'm finding troubleshooting this software is a bit tricky...) The code I need to run uses MPI libraries.

I've installed VS 2018 + Parallel Studio + MPI services as recommended on the Intel website (here - The hydra_service is running fine, and I can see all of the requisite files in the Intel folders.

I've used the recommended settings in the project from here ;

However, when I try to build my test project (a simple hello world one, with MPI), it won't build, and won't run.

I'm getting the error messages:

error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [MPI]

Project : warning PRJ0018 : The following environment variables were not found: $(I_MPI_ROOT)

And I don't know how to fix it... 

I would really appreciate some ideas / directions about what's going on, and how to fix it. 

Thank you!


0 Kudos
4 Replies

The instructions told you to use the I_MPI_ROOT environment variable, assuming that it would be defined system-wide.  

Here's my suggestion.   Open a command windows, and invoke the mpivars.bat file as described in the first link you referenced.    Find the translation of I_MPI_ROOT by using the command "echo %I_MPI_ROOT%"

Then, go back into Developer Studio, and where you had specified $(I_MPI_ROOT) before --- replace that with the value you got in the command window/.

         Let us know if that worked for you --




Hi Lorri,

thank you so much for your reply, it worked! 

Also, it seems that some of the files didn't install properly... after 4 hours of tinkering and re-installing, the original links worked. So the project seems to be building ok! 

However, I'm now getting another error message - when I click on Debug x64, the output window spits out the following, and I don't get any results. 

Any thoughts? 




'mpiexec.exe' (Win32): Loaded 'C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2018.2.185\windows\mpi\intel64\bin\mpiexec.exe'. Cannot find or open the PDB file.

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2018.2.185\windows\mpi\intel64\lib


The thread 0x159c has exited with code 0 (0x0).

The thread 0xe28 has exited with code 0 (0x0).

The thread 0x32fc has exited with code 0 (0x0).
'mpiexec.exe' (Win32): Unloaded 'C:\Windows\System32\NapiNSP.dll'
'mpiexec.exe' (Win32): Unloaded 'C:\Windows\System32\pnrpnsp.dll'
'mpiexec.exe' (Win32): Unloaded 'C:\Windows\System32\nlaapi.dll'
'mpiexec.exe' (Win32): Unloaded 'C:\Windows\System32\winrnr.dll'
'mpiexec.exe' (Win32): Unloaded 'C:\Windows\System32\FWPUCLNT.DLL'
The thread 0x3d3c has exited with code 0 (0x0).
The thread 0xa0c has exited with code 0 (0x0).
The thread 0x3908 has exited with code 0 (0x0).
The program '[14924] mpiexec.exe' has exited with code 0 (0x0).

These messages do not show an error; exiting with code 0 indicates success. 

mpiexec.exe (the "launcher" for MPI codes) is not built with debug, and no PDB file should be found.

In general, you can ignore messages saying "PDB file not found" for any file you did not build.

Finally, I looked at the file you attached, and it's just module code.

What sort of output were you expecting?



Hi Lorri,

Oops, don't worry about the attached file. I had a different question, hence attaching the file, but it got resolved by itself over the weekend. I couldn't delete the attachment though... 

Great to hear that the PDB thing is not an issue, and that code 0 means success. It's not intuitive for the beginners ;) 

One last question, if I may... I would like to get the CUDA / NVidia plugin working with this file.  I have a good video card in my machine that can function as a GPU. I've installed the required software already, and can see the Nsight tab in Visual Studio.

But the documentation I have found so far on the internet is scant. Would you be able to suggest any resources or locations for instructions re: how to get it working?

Thank you,