Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
27417 Discussions

VS2017+IVF2017+Windows10enterprise, VS integration failed

An_N_1
New Contributor I
348 Views

Install VS2017+IVF2017 on some PCs. Most are successful installed except one PC.

I uninstall/reinstall VS/IVF times, each time the installation is completed but VS integration does not effective. Fortran entries cannot be found in VS environment.

I found the difference is that the OS is Win10 enterprise and others are window10 professional. If I change the OS to win10 pro, everythings is OK.

I don't know if it is universal since I have only one case. Just for reference.

0 Kudos
4 Replies
JohnNichols
Valued Contributor II
348 Views

Depends on the version of Windows 10 you are using, but a recent update - about a month ago disabled something in VS2017 and broke the integration with IVF.  It took to the next update round to fix as reinstalls did not work.

 

Devorah_H_Intel
Moderator
348 Views

Please refer to this article for workaround and other information regarding this integration issue:

https://software.intel.com/en-us/articles/intel-software-development-tools-integration-to-vs2017-iss...

An, thank you for the report. I will update our engineering with this particular test case. If you could please provide install logs.

 

tkibedi
Beginner
348 Views

I have a set of Visual Studio installations (2012, 2013 and 2017-community edition) and versions Intel fortran from the last 6-7 years, which have been updated several times. The latest one is Intel Parallel Studio XE 2018 Update 3. After installing this version of Intel compiler, I could compile my existing codes, but using the Debugger in Visual Studio I could not see or edit the parameter values. In a desperate attempt, I just uninstalled all versions of Intel Fortran and only reinstalled XE 2018 Update 3, but the problem persists. Any suggestion to resolve this issue?

mecej4
Black Belt
348 Views
Reply