Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
27427 Discussions

Visual Studio debugger uses C, not Fortran, in locals window, with oneAPI

Steve_Lionel
Black Belt Retired Employee
3,022 Views

You'd think that I would not need help with something like this, but...

I have a new PC on which I installed VS2019 Community and the oneAPI HPC Toolkit. Everything works except, in the debugger, the Locals window uses C and not Fortran type descriptions and it doesn't understand some Fortran variables at all. I had this issue on my old PC, but an uninstall and reinstall fixed it. Not this time. I uninstalled both oneAPI and VS2019, deleted the VS folder, reinstalled both. Same behavior.

Any clues as to how to get the Fortran debug support working would be appreciated.

0 Kudos
1 Solution
Steve_Lionel
Black Belt Retired Employee
2,516 Views

"as a trial"? The oneAPI installs don't have trials - they are simply free. Nothing is going to run out.

What wasn't known when I entered this thread is that the Fortran debugger support for Visual Studio is contained in the "Intel Distribution for GDB" from the oneAPI Base Toolkit. So, if you install that, the debugging should work. I am told that a future update will move this to the HPC Toolkit.

 

View solution in original post

27 Replies
jeffhamann
Beginner
727 Views

I've added the "Intel Distribution for GDB" package from the oneAPI and I now have debugging debugging capabilities. Woot woot!

What I don't understand is why I'm no longer receiving "The operation could not be completed" message. 

Happy days are here again. 

ferrad1
Novice
192 Views

While playing with a mixed language C++ / Fortran test solution over the last few weeks, I noticed that my debugging watch window was displaying variables in C style.  I went back to my major project (which I haven't worked with for a month or so) and noticed that the same was now happening there - it was always in Fortran, so something must have changed at some time.  I can't think what as I have not reinstalled or modified IVF or VS2019. 

I went into Modify IVF install (Intel oneAPI Base Toolkit v. 2022.2) and the component "Intel Distribution for GDB*" is installed.

Any idea on what I should do to get my Watch window in Fortran again??

ferrad1
Novice
181 Views

I uninstalled and reinstalled IVF Base and HPC, and the problem has been solved!

sylvian_k_
Beginner
484 Views

My experience:

 

Installed Base & HPC online. Result: missing mkl, debugger & Python. Downloaded the local version of Base. Operated and clicked Modify. On the Modify screen added the above packages both for VS17 and Vs19.  I checked the debugger on VS19 and it is working. VS19 is still very very slowww for Finding in files - Find Alln even for small solutions.

Gaby_S_
Beginner
414 Views

Hi, I have installed the local versions of both oneAPI BaseKit & HPC tools on VS17. The release parallelised (OpenMP) version of my Fortran codes runs fine but I am still unable to debug. Has anybody managed to recover the Fortran debugging capabilities on VS17? Do I need to get VS19?

Thanks.

andrew_4619
Honored Contributor II
399 Views

Fortran Debugging in vs2017 works as normal with OneApi for me

Gaby_S_
Beginner
382 Views

Thank you for your reply.

It seems that the installation sequence is important: I just reinstalled it starting with HPC tools and adding BaseKit afterwards and it works OK. Previously I did it in reverse order. Of course, one needs to replace the deprecated compiler options  with the new ones ((/extend-source:132, /Qopenmp-stubs for Debug). I did it in Project-> Fortran->Command line: Additional options. It's working fine both in Debug and Release mode now. 

Reply