Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
27551 Discussions

error #7001: Error in creating the compiled module file [module name]

lingai
Novice
368 Views
I was using the visual studio parallel version 2011 with intel compiler to compile my code by the command: ifort mymain.f90 /heap-arrays /Qmkl:parallel solver*.obj preconds*.obj It works well and generates executable files.

But now I changed my workstation, I have to try using visual studio 2022 community version with the Intel oneAPI HPC toolkit.

ifort mymain.f90 /heap-arrays /module:"C:\Program Files (x86)\Intel\oneAPI\mkl\latest\include\intel64\ilp64" /4I8 -I"C:\Program Files (x86)\Intel\oneAPI\mkl\latest\include" solver*.obj preconds*.obj

Above is the command. I have the main code, mymain.f90, and two subfolders including some *.obj files. In my main code, I have three modules to define the variables. When I compile it, I have errors with each of the modules: error #7001: Error in creating the compiled module file [module name]

I'm quite new with the compiler commands, I used Intel® oneAPI Math Kernel Library Link Line Advisor to generate the Compiler options. I was wondering if anyone knows what's wrong with my commands or some related settings?

Labels (2)
0 Kudos
1 Solution
jimdempseyatthecove
Black Belt
349 Views

I suspect that the cause is a module file that is to be created (but fails) is due to the module output folder being a system folder (write protected folder). IOW you are outputting to "C:\Program Files (x86)\...".

Your modules should never be written to a system folder.

 

Jim Dempsey

View solution in original post

4 Replies
jimdempseyatthecove
Black Belt
350 Views

I suspect that the cause is a module file that is to be created (but fails) is due to the module output folder being a system folder (write protected folder). IOW you are outputting to "C:\Program Files (x86)\...".

Your modules should never be written to a system folder.

 

Jim Dempsey

lingai
Novice
313 Views

you are right, I know how to do it, thank you so much

Ron_Green
Moderator
131 Views

I hope that is the problem. But ...

the HPC Toolkit does NOT provide MKL.  did you download the oneAPI MKL separately, or are you using your older MKL installation?

MKL is in oneAPI Base Toolkit or you can install it by itself simply using THIS article.

lingai
Novice
118 Views
thank you. I installed both base and HPC toolkit. Jim is right on that, the problem is with the module folder name.
Reply