Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28548 Discussions

fatal error LNK1104: cannot open file 'ifconsol.lib'

patkins
Beginner
1,921 Views

I originally installed the last 10.x release of the C++ and Fortran Intel compilers and built my mixed language projects upon those compilers in Visual Studio 2008 without any problems. I then upgraded to 11.061 or 11.062, converted the projects and was able to compile without any problems. Now that our license purchases went through I went to version 11.066. I uninstalled the old compiler suites and repaired VS2008 back to its original configuration after the installs. I then installed the version 11.066 compilers but I cannot get the linker to work correctly. When I run the debug compiler I get the following error when the linker is run:

fatal error LNK1104: cannot open file 'ifconsol.lib'

I get similar errors when I compile for release and this is the same for both 32 bit and 64 bit compiles.

error #11017: Cannot open ifconsol

error #11017: Cannot open libifcoremt

error #11017: Cannot open libifport

It seems like it cannot find the Fortran libraries when linking, but I can confirm that the libraries were installed in the appropriate library paths. I have checked the settings in Tools->Options->Intel C++/Fortran->Compilers to make sure the paths are correct. The environmental variables are of a different format than in ver. 10 but they seem to be correct for the library path (I also tried replacing them with the correct path explicitly but I still got the same linker errors). Plus if the root paths were incorrect I do not see how the compiler executable would have been run.

0 Kudos
2 Replies
patkins
Beginner
1,921 Views
I found a solution, it was in the last post of:

http://software.intel.com/en-us/forums/showthread.php?t=42071

I saw this earlier but I missed that he had placed the Fortran library path in the C++ library path. Doing so corrected the linker problems I had but I needed to use the $(IFORT_COMPILE11) environmental variable as opposed to the default environmental variable that was used. So I added:

$(IFORT_COMPILER11)libia32

$(IFORT_COMPILER11)libIntel64

to the C++ library paths for the 32 bit and 64 bit configurations respectively.

0 Kudos
sarma_amras
New Contributor I
1,921 Views
Quoting - patkins
I found a solution, it was in the last post of:

http://software.intel.com/en-us/forums/showthread.php?t=42071

I saw this earlier but I missed that he had placed the Fortran library path in the C++ library path. Doing so corrected the linker problems I had but I needed to use the $(IFORT_COMPILE11) environmental variable as opposed to the default environmental variable that was used. So I added:

$(IFORT_COMPILER11)libia32

$(IFORT_COMPILER11)libIntel64

to the C++ library paths for the 32 bit and 64 bit configurations respectively.


One other way to accomplish the same is to include the path of the library in the Tools -> Options -> Library -> include the path of ifconsol.lib

0 Kudos
Reply