Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
505 Discussions

Run simulation generated by HLS tool

VenkateshSathar
New Contributor I
376 Views
We are evaluating the hls tool in quartus standard 19.1, on a windows 10 machine. We first started with the counter example provided with the hls software. The command log is attached together in this post. The following list is the steps which we have tried

1. compile test-x86-64
2. run test-x86-64.exe
3. compile test-fpga
4. run test-fpga.exe
5. open the generated project in Quartus, and can compile successfully
6. run test-fpga.proj simulation manually in Modelsim
    1. open ModelSim in Transcript mode --> `vsim -c`
    2. run the content in the file test-fpga.prj/verification/tb/sim/mentor/msim_run.tcl
    3. but ModelSim crashed

Step 1 to 4 all ran fine. Then, we had a need to run manually simulations which are generated in the folder test-fpga.proj/verification. However, Modelsim crashed and show error `Trouble with Simulation Kernel`. We are not so sure how to continue now!!??

Our windows specs: win10, 16Gb RAM, 10 cores
We are using Quartus standard 19.1

 

0 Kudos
4 Replies
VenkateshSathar
New Contributor I
344 Views

i am more familiar with the tools now and found something new. if i run `vsim -do "tb/sim/mentor/msim_run.tcl" `, Modelsim will crash with the reported error. If i run `vsim -batch -do "do tb/sim/mentor/msim_run.tcl" `, it said "Fatal: Exiting VSIM license process". For details, please check the new attached log.

AnilErinch_A_Intel
318 Views

Hi ,

This look more like a modelsim issue,since the automated run based on HLS tool is working fine.

You can refer posts below

https://community.intel.com/t5/Intel-Quartus-Prime-Software/ModelSim-Fatal-Trouble-with-Simulation-K...

https://community.intel.com/t5/Intel-Quartus-Prime-Software/Modelsim-ERROR-failed-to-start-simulatio...

and let us know whether these instructions helps to resolve the issue.

Thanks and Regards

Anil


VenkateshSathar
New Contributor I
294 Views

The 2nd link doesn't have a solution. The 1st link is vague. I don't know which output signals need to be assigned to zero value but I am looking into it. However, it is better for Intel Altera let me know in details how to modify the Modelsim simulation. I would like to restate my issue again after a few re-installations so we can understand the issue accurately

"The Modelsim simulation which is generated by HLS Quartus standard 19.1 Windows 10 virtualbox for the Intel-provided counter cpp example cannot be simulated from ModelSim/vsim software. After `do tb/sim/mentor/msim_run.tcl`, ModelSim can set up and start the simulation. However, after around 12ns in simulation, the ModelSim will crash and throw an error 'Trouble with Simulation Kernel'. If running the simulation by executing hls bin file, test-fpga.exe, the counter can increment correctly up to 100 counts."

I tried with Quartus 21.1 on windows and centos7.5 as well. I see the same problem happens to Quartus Pro 21.1 on Windows 10 virtualbox but it works correctly for centos7.5 vm

VenkateshSathar
New Contributor I
286 Views

I ran the simulation to check the state of signals. From the screenshot, all the signals related to the counter instance are set specific values. Let me know if anything else I can check.

Reply