Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
527 Discussions

how can I fix error while loading shared libraries: libalteracl.so: wrong ELF class: ELFCLASS64

GTese
New Contributor I
690 Views

I use OS ubuntu 20.04. For my project case I use Intel Sdk pfga for Opencl standard version 18.1. after I have generated .aocx and compiling host. When I try to run the following error was generated.

error while loading shared libraries: libalteracl.so: wrong ELF class: ELFCLASS64

 

0 Kudos
5 Replies
AnilErinch_A_Intel
666 Views

Hi

Please check the document below

https://software.intel.com/content/www/us/en/develop/tools/opencl-sdk.html

The supported versions of Operating system are mentioned as 16.04 and 18.04.

Please use any of them because the software would have been validated against them,

For a similar issue please refer

https://forums.intel.com/s/question/0D50P00003yyNaESAU/wrong-elf-class-elfclass32?language=en_US

Thanks and Regards

Anil

 

 

GTese
New Contributor I
507 Views

/usr/bin/ld: skipping incompatible /home/guta/intelFPGA/18.1/hld/host/arm32/lib/libalteracl.so when searching for -lalteracl
/usr/bin/ld: skipping incompatible /home/guta/intelFPGA/18.1/hld/board/de1_soc/arm32/lib/libintel_soc32_mmd.so when searching for -lintel_soc32_mmd
/usr/bin/ld: cannot find -lintel_soc32_mmd
/usr/bin/ld: skipping incompatible /home/guta/intelFPGA/18.1/hld/host/arm32/lib/libelf.so when searching for -lelf
collect2: error: ld returned 1 exit status
Makefile:74: recipe for target 'bin/host' failed
make: *** [bin/host] Error 1

GTese
New Contributor I
516 Views

I have changed my OS to ubuntu 18.04, but still the error no fixed for me. Please ............? 

GTese
New Contributor I
515 Views

I have change the my OS to ubuntu 18.04, but still the problem no fixed. Please help me???

g_flamis
Beginner
188 Views

Did you get to any clue with it?

I have similar problem with my DE10-nano.  The "libalteracl.so" either with 18.1 or 16.1 images, using the included executables. Below the complete log...

root@socfpga:~# ls -l
total 28
-rw-r--r-- 1 root root 225 Apr 27 2016 README
drwx------ 2 root root 4096 Jan 24 2017 boardtest
drwx------ 2 root root 4096 Apr 27 2016 hello_world
-rw-r--r-- 1 root root 279 Apr 16 2014 init_opencl.sh
drwxr-xr-x 7 root root 4096 Oct 5 2015 opencl_arm32_rte
drwx------ 2 root root 4096 Jan 24 2017 swapper
drwx------ 2 root root 4096 Jan 24 2017 vector_add
root@socfpga:~# sh init_opencl.sh
root@socfpga:~# cd boardtest/
root@socfpga:~/boardtest#
root@socfpga:~/boardtest#
root@socfpga:~/boardtest# ls
boardtest.aocx boardtest_host
root@socfpga:~/boardtest# ./boardtest_host
./boardtest_host: error while loading shared libraries: libalteracl.so: cannot open shared object file: No such file or directory

Reply