Intel® Moderncode for Parallel Architectures
Support for developing parallel programming applications on Intel® Architecture.
1689 Discussions

Running Intel Parallel Debugger with Intel C++ 11.1 on VS 2008 (not Parallel Composer)

Hello black belters and all - I've been able to run and use the entire Intel product suite on Windows VS2008 (Intel C++, Thread Checker, Profiler, VTune in all three modes) on TBB and OpenMP apps - things work great. (I am not saying that it is perfect but it is indeed very good).

And then, there was this one little feature I am trying to run : The Intel Parallel Debugger which is supposedly able to run with Intel C++ 11.1 on VS 2008 (not Parallel Composer of Parallel Studio)

I should say that I got tons of info on the Intel Parallel Debugger concerning its use within Parallel Composer (C++ shipped with Intel Parallel Studio) but the Net is silent as to its use with Intel C++ 11.1.

After installing Intel C++ 11.1 I did check the three Intel exceptions in the exceptions debugging menu but I could not find within the VS 2008 menus anything concerning Intel parallel debugging similar as to that which one finds in the VS2008 menus which has the Composer installed. And when I debug an Intel C++ OpenMP app (debug:parallel and Qopenmp on) I do not get anything on data sharing problems, SIMD inspection, reentrant function calls and OpenMP info.

If any of you guys can point me as to where I can get more info, many thanks,

Any of you guys have any info on this
0 Kudos
3 Replies
Hi Michle,

the Parallel Debugger Extensions that are part of the Intel C++ Compiler 11.1 Pro installation are actually identical (except for version updates) to the ones included in Parallel Studio/Parallel Composer. The behavior should be the same as well.

From your problem description this implies that most likely your installation (registry entries?) got corrupted somehow. If you had the Intel Parallel Studio installed before - coul it be that the uninstall did not complete fully successfully before installing the Compiler Professional package? Could I ask you to try and do a brand new clean reinstall?

Although it sounds as though you really already know all the relevantsteps for succesfully using the Parallel Debugger Extensions let me also point you to an ISN article that focuses on them:

BTW - the standard support forum for debugger issues - since the debugger is shipped and packaged with the compiler - would be the respective compiler forums ... :-)

Thanks - I hope I could help, Rob

Thanks Rob,

Actually I had Parallel Studio installed into VS 2008. I unistalled Composer and installed Intel C++. It looks as though I should unistall everytihng, reinstall VS2008 and then install Intel C++. Since this will take a few hours and it is already late in France I'll do this at the end of the week as I need to be operational these next two days.

I'll report on the results ASAP.

Thanks again for such a fast response.

Follow up on getting Intel Parallel Debugger to work inside Visual Studio 2008 with Intel C++.

0K - I ran some tests by uninstalling and reinstalling VS2008 and Intel C++ 11.1. All is fine however I could not doso with the latest build (051), I had to resort to the 048 build.I do now see the Intel Parallel Debugger.

I had a consistent failure of the Intel Software Setup program with C++ 11.1 build 051- It appears that after installing Intel C++ 11.1 Build 051 over Intel Parallel Studio already installed, some things got messed up - probably a problem with some registry keys. I uninstalled all of Parallel Studio and tried to reinstal 11.1-051 - nogo. Luckily, 11.1-048 did install correctly into VS2008

My conclusion is that when I installed 11.1-051 over Parallel Studio some registry keys got messed up - unistalling the components (Parallel Studio and 11.1-051) did not clean everything - some keys must have remained behind which create havoc when trying to reinstall 051.

Furthermore, I had installed Intel Fortran 11.0 build 066. On trying to unistall it, I getthe message "an unistall instance is running, wait" - this is systematic - rebooting does not change anything - real mess. Probably linked with the fact that C++ 11.1 buil 051 does not install correctly.

I do wish that Microsoft would do more debugging and thus provide its users with more robust installation system.

Thanks to all who contributed to this thread.