Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
23 Views

intel ipp 7.0

i want to write a cryptography program using intel ipp version 7.0 for linux.But after installation process complete ,our system doesnot support the cryptography header file (ippcp.h).i need a help to get out of this problem...kindly send me suggestion for it...
0 Kudos
3 Replies
Highlighted
Beginner
23 Views

Have you obtained the IPP crytography libraries? If not then you will have to make a separate request for it since it is not included in the IPP installer.

Take a look at this page: http://software.intel.com/en-us/articles/download-ipp-cryptography-libraries/
0 Kudos
Moderator
23 Views

That's right. The standart IPP package doesn't contain IPP Crypto package. Crypto libraryavailable as separate installation package.
Two important notes:
1)You must first install the Intel IPP library before installing the IPP cryptography add-on library.
and
2) The version of Crypto package you have to insatll must be the same as version of IPP installed.
for example:
if you have IPP version ( see \doc\ippsupport.txt file )
Package ID: w_ipp_ia32_p_6.1.5.054
then IPP Crypto version must have be the same *_6.1.5.054
--Gennady
0 Kudos
Highlighted
Beginner
23 Views

Hi,
Check if the following link is of any help:
Regards,
Shashi Sinha
0 Kudos