Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SMorr7
Beginner
7,793 Views

USB Power Delivery Driver not working after Win10 Upgrade to v1803

I just purchased the Nuc8i7HVK about a week ago and installed Win10 v1709 without any issues. I installed all the Intel supplied drivers and Device Manager reports that everything is okay. Last night I upgraded Win10 to v1803 and discovered that under device manager, my TPS65988 device, which is the TI USB power delivery device wouldn't load the driver because it says that the device can't start.

Upon further investigation, the properties under the device itself reports DEVICE_POWER_FAILURE. When I rolled Win10 back to 1709 everything reports okay, so this leads me to think this is a Windows issue, but when I try to reinstall the Intel driver after the upgrade, nothing happens.

Two questions:

1. Has anybody else seen this issue after upgrading to v1803?

2. Is there a hardware problem with my unit? (Nothing is plugged in to my USB Type C ports)

Thanks in advance guys!

Tags (2)
15 Replies
n_scott_pearson
Super User Retired Employee
1,718 Views

Yea, I saw this issue when I first upgraded my HV NUC. Whenever I have a problem like this, the first thing I do is right-click on the entry and select Update Driver. In this case, it installed an update and, after rebooting, the problem was gone! Interestingly, I did this again just now -- and the problem is back! It looks like there is a bad driver version on Windows Update. I uninstalled the driver (including deleting files) and then rebooted. It came back up, installed driver and now is working cleanly again. Bizarre.

Obviously, this isn't a hardware problem.

...S

idata
Community Manager
1,718 Views

Hi I will give this a go and see what happens will report back with results

Did some digging and noticed a Driver Error

look at the Driver date and the version number they appear to be wrong

Driver Version 1.0.2.6 the one causing the problem has a Driver date of 13/04/2018

Driver Version 1.0.4.5 the new Driver has a Driver date of 26/12/2017

I believe the Driver Date was causing the problem others and my self was or are getting.

I have been running transfer between 2 External Drives connected to the USB-3 and getting a constant transfer rate with no errors popping up.

Snap Shots taken of the Conflicting Dates for the drivers

PC specks are

Intel® NUC Model NUC8i7HVK

Intel Core i7-8809G 3.1GHz (up to 4.2GHz Turbo)

2x 16GB DDR4 2400+ SODIMMs

Radeon RX Vega M GH 1063-1190MHz GPU, 800MHz Memory 4GB

512 GB M.2 SATA SSD Operating System and Apps

1TB M.2 SATA SSD Game only Windows and Steam

2 TB External Hard drive USB 3 for Photos and Back up files

<span style="display: inline !important; float: none; background-color: transparent; color: # a1a2a5; font-family: 'Segoe UI','SegoeWP'; fon...

idata
Community Manager
1,718 Views

Have you managed to resolve this problem would be nice to know As I had the same problem and it now appears to be fixed

NEmbu
Beginner
1,718 Views

I have the issue. I applied your solution by uninstalling the device and deleting the driver. However, the same error kept happening after restarting my NUC. I tried looking for the updated drivers, but no luck. Kindly send the link for the new driver. Thanks

idata
Community Manager
1,718 Views

Date: Fri, 29 Jun 2018 16:07:18 +1000

 

Subject: Re: [Intel(R) NUC] - USB Power Delivery Driver not working after Win10 Upgrade to v1803

 

Hi when you Uninstall the device and Drivers do not re boot till you do the driver install oce you do the install then reboot, you may have to do it a couple of times before it takes. Have spoken to Simply NUC and apparently the driver in windows was rushed with out correct testing the one from the Intel site should work.

This Link for all the NUC Drivers

 

https://downloadcenter.intel.com/product/126143/Intel-NUC-Kit-NUC8i7HVK

This one just for the USB-C Power management

 

https://downloadcenter.intel.com/download/27721/NUCs-USB-Type-C-Power-Delivery-Controller-for-Intel-...

Good Luck Alan J T

Chris_V_Intel
Moderator
1,718 Views

Thanks for helping out!

JHall8
Beginner
1,718 Views

How do you identify the driver to uninstall under Device Manager? This continues to be an issue. When will a fix be performed by Intel NUC? Thanks

idata
Community Manager
1,718 Views

Ok so just find it in your list uninstall it making sure the box circled is ticked then install the correct driver and it should be fine after that

This one just for the USB-C Power management

 

https://downloadcenter.intel.com/download/27721/NUCs-USB-Type-C-Power-Delivery-Controller-for-Intel-... https://downloadcenter.intel.com/download/27721/NUCs-USB-Type-C-Power-Delivery-Controller-for-Intel-...

Good Luck Alan J T

JHall8
Beginner
1,718 Views

So its under System Devices.

Thanks Alan!

idata
Community Manager
1,718 Views

Happy to help

JNevi
Beginner
1,718 Views

I have a Lenovo Yoga 910 with this same problem.

Can you point me to a driver for that model?

Thank you

pren
Beginner
1,718 Views

It looks like the Driver Date goes wrong.

To me , there is some confusion about what the right procedure should be.

Try this way to resolve this issue.

  1. Uninstall TPS65988 device under the Device Manager, and delete the driver software for the divice.
  2. Use 7-Zip to uncompress the USB_C_Power_Delivery_Win10_64_1_0_4_5.msi .
  3. Install the TPS6598x.inf .
  4. Scan hardware update under the Device Manager, You'll find Ti USB Type-C/Power Delivery Controller on the list.

That's all.

LSkin
Beginner
1,718 Views

Thank you, this fixed the issue I was having too! For me the steps fixed it were:

 

1) Download the update msi file, but don't run it yet: https://downloadcenter.intel.com/download/27721/NUCs-USB-Type-C-Power-Delivery-Controller-for-Intel-...

2) Go into Device Manager and Unistall the TPS65988 Device - make sure you tick the "Delete the driver software for this device" box.

3) Run the "USB_C_Power_Delivery_Win10_64_1_0_4_5.msi" update file extracted in step 1) to install the driver.

4) Reboot

 

I guess the issue could be because even though the driver is a new version 1.0.4.5 vs 1.0.2.6, the date is older 26/12/2017 vs 13/04/2018 ?

 

Anyway, I'm happy that it's fixed! 😁

THamm3
Beginner
1,718 Views

I had this problem as well and tried just about every method the forums suggested. Then, as I was doing some additional investigation, I found the Thunderbolt Bus Driver and I thought maybe it had something to do with the issue. So, I did the following:

1) Download and unzip "tbt_win10_64_17.4.77.400.zip" (follow this link: https://downloadcenter.intel.com/download/28658/Thunderbolt-Bus-Driver-for-Windows-10-for-Intel-NUC-...)

2) Open the folder #1 was downloaded in to and select "setup.msi"

3) When the Change, repair or remove installation screen appears, select Remove (if enabled).

4) Exit the program.

5) Open your device manager and (under System devices) open the properties of the device TPS65988.

6) Select the Driver tab and then select Uninstall Device.

7) In the Uninstall Device window, check Delete the driver software for this device.

8) Click Uninstall.

9) Reboot your PC

10) In the folder created in step #1, sinf and select "setup.msi"

11) Select Install to install the software.

12) Download and run "usb_c_power_delivery_win10_64_1_0_4_5.msi" (follow this link: https://downloadcenter.intel.com/download/27721/USB-Type-C-Power-Delivery-Controller-for-Windows-10-...)

13) Follow instructions to install the driver(s)

14) Reboot your PC

 

If all works for you as it did for me, your device should no longer show up having failed.

 

Now, off to figure out why my bluetooth doesn't always start when I fire up the NUC

Reply