Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SVive1
Beginner
5,691 Views

Cannot turn Optane "online"

I've had an ongoing issue with my Intel Optane 32 GB for over 2 weeks now. I had the device installed in a new PC I ordered from CyberPowerPC and it was running fine. 2 weeks ago however my Windows became corrupted because of a bad patch they released and I had to do a complete Operating System reinstall, in order to do so I had to disable the Optane first. After doing so and reinstalling Windows 10 I have tried for long hours and several days talking with their tech support trying to get my Optane working again but it will not. I've looked at numerous guides online trying to get it fixed and couldn't find the answer.

I have the Intel RST installed and the drivers as well (to the best of my knowledge. The device does not show up in this program). However in Disk Management my Optane Drive is being listed as Offline, any attempt to right click the drive and set it to Online is met with a popup saying "The parameter is incorrect". Also oddly enough in Disk Manager it is showing the Optane as having the same drive capacity as my HDD (I should note i am trying to install this on my secondary drive, as it originally was). My SSD is used for my operating system and is connected to an M2 slot so it does not need acceleration (this is how I asked it to be set up when ordering the pc, and like I said I had no problems before).

I can't for the life of me figure out how to get this to turn Online, I was told by CyberPowerPC to try to remove and put the optane back into the same slot, again which I did and it changed nothing. After a week of messaging them for some reason they have stopped replying to me and I haven't heard from them at all last week about my problems with the device and now I am here trying to get assistance. I have also just tried to shrink the drives by 5mb to make sure I have the unallocated space on them but it doesn't seem to have made any difference, and because I am assuming the size is so small I can't even see the change on disk manager.

I have attached a picture of the Diskmanager screen as I try to turn the device online and all other pictures I thought might be relevant, you can also see the odd capacity size on it as well. I will note that my BIOs is also updated with all the current drivers (ASUS Prime Z370-P).

0 Kudos
42 Replies
idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

Thank you for posting in the Intel® communities.

 

 

This is the second time I see a report of this issue. I saw it the first time in this post: https://communities.intel.com/message/572358# 572358 https://communities.intel.com/message/572358# 572358

 

 

The user in that thread resolved the issue by just restarting the computer. However, if this doesn't work, you can try to remove the SATA drive from the system and boot again without the drive to see if the module still appears as offline.

 

 

Apparently, this issue is because there are two drives with the same disk signature in your system, so one of them appears as offline. Chances are that if you remove the HDD, the module may appear as online again. You can check the following information for additional details: https://neosmart.net/wiki/disk-signature-collision/

 

 

If you are able to make the Intel® Optane™ Memory online again, please follow these steps to clean the module and delete any data stored in it:

 

  1. Open the Command Prompt as Administrator.
  2. Run the command diskpart.
  3. Run the command list disk. You will see all your drives, including the Intel® Optane™ Memory. Take note of the ID associated with the module.
  4. Run the command select disk . Use the ID number for the Intel® Optane™ Memory.
  5. Run the command clean all to start the process. This process will delete all data in the module, so make sure you actually selected the module and not another drive by mistake.

 

Once this is done, you can add again the HDD and see if everything is working fine.

 

 

I'll be waiting for your results.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
SVive1
Beginner
926 Views

I've managed to get the optane to show as online with your suggestion, but now i am having difficulty figuring out how to enable it. I still can't see the optane listed in Intel RST. I'll continue trying to figure it out.

Upon trying to uninstall RST, I can't seem to get anything to happen. When I go to uninstall programs and select RTS there's a brief loading icon and then nothing happens and its still installed.

So I managed to get RTS uninstall by ending processes on my computer from intel, however I am still getting some problems. After installing the SetupOptane.exe and running it, during the restart computer phase my PC attempts to restart with Optane enable but I get a blue screen and Windows is unable to boot, this just loops until i turn off the optane and put it back to AHCI.

idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

This issue may be related to how the booting drive is currently partitioned.

 

 

Please run again the Intel® System Support Utility (SSU), but this time run the full report and attach the output file in your response.

 

 

Additionally, please follow these steps and take a screenshot of the screen:

 

  1. Open the Command Prompt as Administrator.
  2. Run the command diskpart.
  3. Run the command list disk. You will see all your drives, including the Intel® Optane™ Memory. Take a screenshot of this output.

 

I'll be waiting for your response.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
SVive1
Beginner
926 Views

Here are the files you requested.

idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

Thank you for the information.

 

 

According to the report and the screenshot, everything looks fine. I was thinking that the reason you weren't able to boot after configuring the BIOS was because the drives were using MBR partition style, but they are using GPT so it's fine.

 

 

Having said this, the only reason I can think of is your Windows* OS build version. According to the report file, your build version is 15063. Once, I tried to setup up the Intel® Optane™ Memory in a Windows* 10 OS build version 15xxx (I don't remember the exact version), but I couldn't because of the build version. When I tried to change the BIOS configuration, the system didn't boot unless I changed it back to AHCI mode. I had to use another build version (17xxx) to be able to setup the Intel® Optane™ Memory.

 

 

Having said this, my recommendation would be to use another Windows* 10 build version in order to setup your Intel® Optane™ Memory, as the issue is most likely because of the version you are using.

 

 

On the other hand, please try to set the following BIOS settings just to see if you are able to boot. If this doesn't work, then my recommendation would be to change/update the Windows* OS build version:

 

  1. Go to BIOS.
  2. Change the SATA Mode Selection to Intel RST Premium with Intel Optane.
  3. Set the option M.2_X PCIE Storage RAID Support to Enabled.
  4. Set the option Launch CSM to Disabled.

 

After performing these changes, please try to boot. Additionally, I recommend you to check the following ASUS* guide that explains how to configure the BIOS. Notice that there are two approaches. The second one is the recommended one and it refers to the settings I mentioned above. However, the first approach can be used if your system is in AHCI mode, so it may work for you: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

 

 

Finally, there is another detail that you are missing. There should be at least 5MB of reserved space at the end of your booting drive. This space is used by the module in order to work properly. Please check the following document (page 5) for details about this reserved space. You can reserve it during the OS installation process: https://www.intel.com/content/dam/support/us/en/documents/memory-and-storage/optane-memory/intel-opt...

 

 

I hope you find this information useful. I'll be waiting for your results.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
SVive1
Beginner
926 Views

None of what you suggested worked, and I'm not sure how to change my Windows build.

For my BIOs settings, when I set the SATA mode to Intel RST Premium the only options for the M.2 PCIE are "RTS Controlled" or "Not RTS Controlled", and there are two PCIE option areas, with the same options. It's always defaulted to RTS Controlled.

In the ASUS guide my default Boot/CSM options were all set to UEFI driver first, none were Legacy only (the top option was UEFI and Legacy OPROM), tried changing it but it didn't work. The second part instructions seem messed up, it says "You may then set the CSM to disabled and set the Boot from Storage Devices option to UEFI driver first.", but as soon as you set CSM to disabled, all the lower options disappear, so that didn't work either.

Also I do have 6MB of unallocated space on my boot drive (C:), but I'm guessing the size is too small to show in the Manager bar view.

I'm also not sure if I am installed in RAID. Unless it is a default option, I didn't select it.

idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

You can update your Windows* OS version as it's explained in the following Microsoft* article: https://support.microsoft.com/en-us/help/4027667

 

 

On the other hand, I recommend you to contact ASUS* for assistance on how to configure the BIOS properly. The only information I can use to help you configuring the BIOS is the one in the document I shared with you, but besides that, it would be hard to help you as I don't have access to the BIOS options: https://www.asus.com/us/Motherboards/PRIME-Z370-P/HelpDesk/

 

 

However, and as I mentioned in my previous post, it is most likely that this issue is because of the Windows* version. I recommend you to try to update your Windows* version to a recent build and then try to setup the BIOS again.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
SVive1
Beginner
926 Views

Well I checked windows updates and updated everything and got to a higher version. Tried some of the changes to the BIOs options again and then something royally messed up, because I got a different blue screen error, windows tried to repair itself, but couldn't. Then I couldn 't even boot back up into AHCI and I have to reinstall windows again.

Do you think getting a replacement Intel Optane drive from the place I bought it would change anything?

idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

Thank you for the response.

 

 

I don't think that the issue is the Intel® Optane™ Memory, but a configuration at BIOS/OS level. If I'm not mistaken, you should experience this same behavior whether the module is connected or not to the computer.

 

 

After the re-installation of the OS, did you go back to version 15063, or the Windows* update is still applied? Additionally, when you re-install the OS, was the Legacy mode completely disabled (CSM disabled) and the SATA mode selection was set to Intel RST? If not, can you tried to re-install the OS with these settings in BIOS? The way the BIOS is configured when the OS is installed defines the way the OS is actually installed. If you are using an OS image with an old build version (15063), I recommend you to get a newer image (17xxx or later) so that the OS is installed with a recent build version. It may be possible that this is the cause of the issue.

 

 

On the other hand, let's try one more time to configure the BIOS, but this time please remove the Intel® Optane™ Memory from the system to make sure the module is not affecting in any way. If possible, please take screenshots of the BIOS settings so that I can take a look at them. You can take screenshots of the BIOS by pressing F12 or the Print Screen button. You will require a USB Flash memory connected because the images are saved there automatically. Please refer to this site for additional details about this: http://www.unboxingtreatment.com/2018/04/howto-take-screenshot-motherboard-bios.html

 

 

Please follow these instructions in order to get all details about your system:

 

  1. Please take screenshots of the BIOS settings. Please disable the CSM setting to make sure the system is using only UEFI mode. The SATA mode selection should be set to Intel RST Premium. With the screenshots I can have a better understanding of the settings available.
  2. Additionally, please confirm which ports your drives are connected to. This information is usually seen on a tab called Peripherals, but it may vary on your BIOS menu.
  3. Go to Windows* and run again the Intel® SSU report, and take a new screenshot of the Disk Management window.
  4. Still on Disk Management, please right click on each drive and select Properties>Volumes tab. Take a screenshot of this information too to confirm both drives are using GPT partition style.

 

Basically, what we have to confirm is that both drives are using GPT partition style, the partitions on each drive, the mode the system is working on (Legacy or UEFI), the Windows* OS version, the specific ports where the drives are connected to, and the BIOS configuration.

 

 

If you have not tried to configure the BIOS without the module attached, please do it just to confirm the issue is not related to the module.

 

 

Additionally, I would like to know if you tried the first approach described in the ASUS* document. This approach is used when the system is in AHCI mode. Maybe this process works for your system. In order to try this approach, please uninstall first the Intel® RST application and then install the Intel® Optane™ application, otherwise there would be a conflict and you won't be able to install it until you uninstall the first one: https://downloadcenter.intel.com/download/28256/Intel-Optane-Memory-User-Interface-and-Driver-for-Sy.... Before running the application, make sure to connect again the Intel® Optane™ Memory.

 

 

Please try this. I'll be waiting for your response. If you have any doubt with any part, feel free to ask.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
SVive1
Beginner
926 Views

As far as Windows goes, I've always used the disk I recieved with my PC, I'm not sure how to do it any other way, I am however installing Windows updates to.a higher version immediately after install.

I didn't check any of the settings when I installed this OS, I left them at default and only choose to boot from the DVD drive. I'm not sure what version I had this last reinstall, as I tried the save personal files option during reinstall, previously I had to update right away, like I said probably because I'm using a disk.

I have tried the Optane application as well as the RTS one, however only the RTS is available for download on my motherboard website, and the other I got from the Intel website.

I'll have to update you more when I get home from work.

idata
Community Manager
926 Views

Hi Ccloudff7,

Thank you for the information.

Please try the suggestions in my previous response when you have the chance.

For your reference, I will leave below the direct links to the latest versions of both, the Intel® RST application and the Intel® Optane™ memory application.

https://downloadcenter.intel.com/download/28255/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf... Download Intel® Rapid Storage Technology (Intel® RST) User Interface and Driver

https://downloadcenter.intel.com/download/28256/Intel-Optane-Memory-User-Interface-and-Driver-for-Sy... Download Intel® Optane™ Memory User Interface and Driver for System Acceleration

Have a nice day.

Regards,

 

Diego V.
SVive1
Beginner
926 Views

I'll have to try more over the weekend, I'm getting pretty exhausted spending so much time doing this on a daily basis. I'm starting to think the time I waste trying to fix it will never be made up no matter how fast the optane accelerates my drive.

idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

I completely understand what you are saying.

 

 

Considering that this issue seems to be related to the BIOS/OS configuration, I highly recommend you to contact ASUS* to get assistance on how the BIOS should be properly configured. They may be able to provide you with additional suggestions on how to configure the module in the system.

 

 

On the other hand, I'll be waiting for your results after the weekend. If possible, please re-install Windows* with the BIOS settings mentioned above and make sure to update the build version before doing anything else to make sure you are using a recent build version. Remember to reserve 5MB or more of unallocated space at the end of the booting drive.

 

 

If possible, please take all the screenshots I mentioned above. They will be very useful in order to help you with this.

 

 

Regards,

 

Diego V.
SVive1
Beginner
926 Views

Just to verify, when you said "Additionally, when you re-install the OS, was the Legacy mode completely disabled (CSM disabled) and the SATA mode selection was set to Intel RST? If not, can you tried to re-install the OS with these settings in BIOS?", this isn't the setup to use the Optane on the OS drive is it? Because I don't want to accelerate my OS boot drive, that drive is already an M2 PCIe SSD, I'm trying to set it up on my Secondary HDD that doesn't have the OS on it. Which is somewhat leading me to believe that is why it says no operating system detect...because the optane is to be attached to a secondary. Does it try to boot off the drive the Optane is attached to when you put that setting on?

idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

The BIOS configuration must be properly set regardless of which drive is going to be accelerated. From the Intel® Optane™ Application you can select the drive to be accelerated, but the BIOS settings should still be configured this way.

 

 

The system attempts to boot from the primary drive, but this doesn't depend on the drive which the module is paired with. If the module is paired with the secondary drive, this drive will remain as the secondary drive and the system will still boot from the primary one.

 

 

Actually, that is why I suggested to remove the module from the system so you can configure the BIOS, and then try to boot again. If you are not able to boot (with the module disconnected), the possible reasons would be:
  1. The booting drive is using MBR partition style which is not compatible with UEFI mode.
  2. The Windows* OS version doesn't support the BIOS configuration and it's not able to boot.

 

You can try this without the Intel® Optane™ Memory connected. Actually, you can also remove the secondary drive. Once you change the BIOS settings, re-install the OS and then upload the version only with the SSD connected, you can then add the secondary drive and boot the system. At this point you can be sure that the system is configured properly and the drives, the OS and the BIOS is ready for the Intel® Optane™ Memory. If you are not able to set the BIOS and the OS while the module is disconnected, the root cause is not the module, but something related to the OS. I'm still thinking that the build version might be the reason, but to be sure, you would have to perform this re-installation process without the module, or the secondary drive connected.

 

 

If you can boot from the SSD with everything properly configured, but when connecting the HDD back to the motherboard you are not able to boot anymore, then the issue might be related to the port where the drive is attached to. Some motherboards share bandwidth between M.2 slots and SATA ports, and chances are that you are connecting the SATA HDD in one of these ports. That's why I asked you to confirm where (which ports) the drives are connected to.

 

 

As you can see, there are several things that must be checked in order to isolate where the issue could be.

 

 

If I were you, I would start by the following:

 

  1. Remove the Intel® Optane™ Memory and the secondary drive. Disconnect them from the motherboard. Leave only the SSD.
  2. Go to BIOS and configure all settings as mentioned above.
  3. With the BIOS settings properly set, re-install the Widows* OS in the SSD. Make sure to reserve the 5MB of unallocated space at the end.
  4. After the installation, update the OS version.
  5. Make sure the BIOS settings are still configured in the way you did before starting the re-installation. If you can boot fine, then we can move on.
  6. Re-insert the SATA HDD and boot again the system. If no issues, then we're good.
  7. Install the Intel® Optane™ Application to install the drivers required by the module.
  8. Connect the module again to the motherboard and make sure all BIOS settings are still the same. At this point, it may be necessary to configure one more BIOS setting. This would be the M.2 PCIE setting that you mentioned before. This one should be set to "RST Controlled".
  9. Boot the system and go to the Intel® Optane™ Application. You should be able to select your secondary drive and enable the module. If for some reason you get an error message, it may be possible that the secondary drive must be formatted prior to enable the module and pair it with the drive.

 

Please take screenshots so I can help you on this process and to understand on which specific part you are having the issues.

 

 

Regards,

 

Diego V.
SVive1
Beginner
926 Views

OK, well I can't install the OS while the Optane setting is turned on "Intel RTS", i actually remembered the problem I had before. When trying to reinstall with the Windows disk none of the drives (in this case just the 1 connected) are shown and you can't install. So i thought it seems familiar and I looked at an email that I had sent to Tech support from CyberPowerPC previously and they told me that you cannot install Windows with the Intel RTS option enable, so I am at a standstill again and not sure what to do. The Notice pop up happens when i disable the CSM, not sure if it matters, but when i disable it there are no other options listed below CSM.

i will not that the option with Intel RST Premium.... it says (RAID) at the end. Could it be possible it needs to be in this "RAID" mode? I have no idea how to do that.

I will also note that I tried again to boot with the Intel RTS Premium enable, and CSM off, and I got that Blue Screen again with broke my OS when i let it loop 2-3 times, this error says: SYSTEM THREAD EXCEPTION.

SVive1
Beginner
926 Views

Here are some more pictures. I almost thought I messed up the OS again because i got the same message I did before when I messed up a repair or something, i'll post the picture.

And yes I have checked all my drives, in Volumes all of them are set to GPT (added picture).

idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

Thank for the information.

 

 

Based on your description and the pictures attached, the root cause is the Windows* OS version that you are using. This version doesn't allow you to install the system in UEFI mode. UEFI mode is set once you disable the CSM setting. It's normal that when you disable the CSM setting, all other options are hidden because they are for Legacy purposes.

 

 

This is the reason why your OS ends in a blue screen once you change the setting. This should not happen on newer versions (17xxx or higher). Probably, your OS version doesn't have the necessary UEFI driver and that's why the blue screen happens.

 

 

As I explained you in a previous post, I had a similar issue while trying to setup the Intel® Optane™ Memory using a 15xxx Windows* 10 version. I couldn't install the OS if the CSM setting was disabled, and if I changed the CSM setting after the installation, I was not able to boot. Although the issue is not exactly the same one because I didn't get any blue screen (the drive was simply not detected to boot from it), this issue is also caused by the Windows* version.

 

 

You would have to get a new Windows* OS image with a newer version and perform a clean installation process. I'm aware that you are installing the OS from the DVD you have, however you can also create a USB media to boot from it and install a newer Windows* version.

 

 

There are several guides from Microsoft* that explains how to do this, but I found another website with similar (and easier) instructions to create a USB media so that you can install the OS from it instead of using the DVD. This process should fix the issue and you should be able to install a newer OS version.

 

 

Please check the guide in the following site: https://www.windowscentral.com/how-create-windows-10-usb-bootable-media-uefi-support. Basically, you have to download a Microsoft* tool that will help you through the process. The guide is well explained too and it's easy to follow. Please try this and let me know your results. If you have any issues, my recommendation would be to contact Microsoft* to get assistance on creating the USB media to boot from it and install the newer Windows* OS version, but I hope you don't have any issues during this process.

 

 

Once you have installed the OS, please confirm which version you have. You can do this by pressing the Windows key + I to open the Settings window. Then go to System>About and scroll down to see the information of your OS version.

 

 

Once you have confirmed your OS version, you can follow the instructions from my previous post of adding the secondary drive and the Intel® Optane™ Memory in order to try to set it up. Make sure you can boot with the BIOS settings properly configured, otherwise the module won't work correctly even though the OS version is a newer one.

 

 

I know this process has taken long, however, now that we have identified the root cause, the issue should be solved. If you have any doubts, please don't hesitate to ask. I'm here to help you in any way I can.

 

 

I'll be waiting for your response.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
idata
Community Manager
926 Views

Hi Ccloudff7,

 

 

I'm wondering if you have any updates about this.

 

 

Regards,

 

Diego V.

 

SVive1
Beginner
269 Views

Sorry I haven't gotten around to trying again yet, I'll probably try tomorrow, I wanted to relax this weekend. I'm confused though, I already have the latest version of Windows, why would I need a brand new install to get the Intel Optane to work, they seems like a bad design choice in that only people who are willing to wipe their OS and reinstall everything would be valid customers to buy the device. I also don't get why the version of Windows I have won't work, its not a very old version, and the latest update just came out, but optane has been out for some time so I don't see why my version wouldn't be compatible with it.

Also for verification, so I don't have to go searching through all the posts all over again, what should I set up, if anything, in my BIOs before I start the fresh install.

Every time I try something I just create more and more problems for myself. When I tried to use the tool you suggested something went wrong and now the usb drive has to be reformated, beside the fact that i lost everything else that I had on the usb drive, its now only trying to reformat as a 32GB usb when its 115Gb. Now I have to figure out what to do, and download another program to get it formatted properly. It's just one headache after another, which is really why I am losing interest in doing this anymore.

So I cleaned the usb and got it back again, retried, same error again, it won't save to the usb.

I don't know, its possible it might not be a windows license that I can transfer and may be tied to the computer since I got the PC from a large distributer (CyberPowerPC). I tried on a different, smaller usb drive and the same error came up again.

i only have limited free time after I get home from work, and I end up wasting hours of it messing with this thing all the time, one issue after another. i would send the PC back for them to figure it out and return it to me, except it would take over a month and I don't feel like waiting that long to use the PC I paid $2000 for after waiting 3 weeks to get it in the first place.

Reply