Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16740 Discussions

Can't launch the Modelsim-Altera Software after the compilation

Altera_Forum
Honored Contributor II
13,180 Views

Hi, 

 

My OS is Windows 7 64 bit. I'm using Quartus II 13.1 Web Edition, and Modelsim 10.1d. When I go Tools > Run Similation Tool > RTL Simulation; I get this Nativelink Error: 

https://www.alteraforum.com/forum/attachment.php?attachmentid=9088  

 

 

 

I checked Tools>Options>EDA Tool Options: 

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=9089  

 

and this: 

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=9090  

 

I tried to change and add the path: "\" or "\." but don't work.  

 

Can someone help me?
0 Kudos
13 Replies
Altera_Forum
Honored Contributor II
8,413 Views

possible idea => might be if you have spaces in your project directory

0 Kudos
Altera_Forum
Honored Contributor II
8,413 Views

 

--- Quote Start ---  

possible idea => might be if you have spaces in your project directory 

--- Quote End ---  

 

 

I have this problem for all the projects I try to simulate and they are in differents directory.
0 Kudos
Altera_Forum
Honored Contributor II
8,413 Views

this post might help, you might need a \ added to the path 

 

http://www.alteraforum.com/forum/showthread.php?t=43012
0 Kudos
Altera_Forum
Honored Contributor II
8,413 Views

Hello kchan, 

 

Have you run at least the Analysis and Synthesis tool ? 

 

Have you checked the log file ? 

 

Can you run modelsim-altera outside the quartus enviroment ? 

 

If I were you I would change the simulation directory in something like: simulation/modelsim instead of C:\altera\13.1\modelsim_ase\win32aloem
0 Kudos
Altera_Forum
Honored Contributor II
8,413 Views

I try to re-install Quartus and Models in a different directory and now are both in folder Quartus-Modelsim and the path of simulation assigned is:  

C:/Program Files/Quartus-Modelsim/modelsim_ase/win32aloem 

 

but even after the re-installation and the change of directory I have SAME problem.  

 

@kuppe I can launch the Analysis and Synthesis tool and it worked without problem.  

I can open Modelsim program without problem but I don't know how lauch a run simulation not started by Quartus. I am a student and I am a very beginner of Quartus but I have to learn to simulate for my exam!  

For the log file do you mean this?  

 

 

--- Quote Start ---  

Info: Start Nativelink Simulation process 

Info: NativeLink has detected VHDL design -- VHDL simulation models will be used 

 

========= EDA Simulation Settings ===================== 

 

Sim Mode : RTL 

Family : cyclonev 

Quartus root : c:/program files/quartus-modelsim/quartus/bin64/ 

Quartus sim root : c:/program files/quartus-modelsim/quartus/eda/sim_lib 

Simulation Tool : modelsim-altera 

Simulation Language : vhdl 

Version : 93 

Simulation Mode : GUI 

Sim Output File :  

Sim SDF file :  

Sim dir : simulation\modelsim 

 

======================================================= 

 

Info: Starting NativeLink simulation with ModelSim-Altera software 

Sourced NativeLink script c:/program files/quartus-modelsim/quartus/common/tcl/internal/nativelink/modelsim.tcl 

Error: Can't launch the ModelSim-Altera software -- the path to the location of the executables for the ModelSim-Altera software were not specified or the executables were not found at specified path. 

Error: You can specify the path in the EDA Tool Options page of the Options dialog box or using the Tcl command set_user_option. 

Error: NativeLink simulation flow was NOT successful 

 

 

 

================The following additional information is provided to help identify the cause of error while running nativelink scripts================= 

Nativelink TCL script failed with errorCode: issued_nl_message 

Nativelink TCL script failed with errorInfo: Can't launch the ModelSim-Altera software -- the path to the location of the executables for the ModelSim-Altera software were not specified or the executables were not found at specified path. 

while executing 

"error "$emsg" "" "issued_nl_message" " 

(procedure "launch_sim" line 85) 

invoked from within 

"launch_sim launch_args_hash" 

("eval" body line 1) 

invoked from within 

"eval launch_sim launch_args_hash" 

invoked from within 

"if [ info exists ::errorCode ] { 

set savedCode $::errorCode 

set savedInfo $::errorInfo 

error $result $savedInfo $savedCode 

} else { 

..." 

invoked from within 

"if [catch {eval launch_sim launch_args_hash} result ] { 

set status 1 

if [ info exists ::errorCode ] { 

set savedCode $::errorCode 

set sav..." 

(procedure "run_sim" line 78) 

invoked from within 

"run_sim run_sim_args_hash" 

invoked from within 

"if [ info exists ::errorCode ] { 

set savedCode $::errorCode 

set savedInfo $::errorInfo 

error "$result" $savedInfo $savedCode 

} else { 

er..." 

(procedure "run_eda_simulation_tool" line 330) 

invoked from within 

"run_eda_simulation_tool eda_opts_hash" 

--- Quote End ---  

wolfram77
Beginner
8,413 Views

This path worked for me: C:/Program Files/Quartus-Modelsim/modelsim_ase/win32aloem 

I am a student and learning to use this.

0 Kudos
Altera_Forum
Honored Contributor II
8,413 Views

 

--- Quote Start ---  

this post might help, you might need a \ added to the path 

 

http://www.alteraforum.com/forum/showthread.php?t=43012 

--- Quote End ---  

 

 

Before open this thread I have already read that post and I already tried but for me that change but don't work.
0 Kudos
Altera_Forum
Honored Contributor II
8,413 Views

Nobody can help me to fix this problem? I really need to simulate for my exam! :(

0 Kudos
Altera_Forum
Honored Contributor II
8,412 Views

I solved this problem by putting an extra \ at the end of the path. i.e. C:\altera\13.1\modelsim_ase\win32aloem 

 

Hopefully that is useful to someone.
0 Kudos
Altera_Forum
Honored Contributor II
8,412 Views

Problem: 

 

My OS is Windows 7 64 bit. I'm using Quartus II 15.0 Web Edition, and Modelsim 13.1d. I can't launch the Modsim-Altera software after the compilation and the compilation is no error and warning. 

 

I checked Tools>Options>EDA Tool Options: 

 

F:\program file(x86)\15.0\modsim_ase\win32aloem,I can't launch the ModelSim-Altera software. The path to the location of the executables for the ModelSim-Altera software were not specified or the executables were not found at specified path... 

 

I trid to change and add the path:"\" or "/" and cut the modsim_ase files to outside of the program file(x86) files.but don't work. 

 

The way of solving the problem: 

 

The path:"F:\program file(x86)\15.0\modsim_ase\win32aloem" includes a blank space,in other words,program file(x86) contains a blank space or '(' and ')'.You should change the path:for example, 

"F:\programfile\15.0\modsim_ase\win32aloem\", 

"F:\altera\15.0\modsim_ase\win32aloem\", 

"C:\altera\15.0\modsim_ase\win32aloem\

 

I try to re-install Quartus and Models in a directory and now are both in folder 15.0 and the path of simulation assigned is:  

F:\altera\15.0\modsim_ase\win32aloem\".It does work!!! 

 

note: 

1.The install and project directory doesn't have blank space. 

2.The default directory path is "C:\altera\15.0".You'd better only change the 'C' to 'F'or other disk.
0 Kudos
Altera_Forum
Honored Contributor II
8,412 Views

Thanks for the sharing.

0 Kudos
Altera_Forum
Honored Contributor II
8,412 Views

 

--- Quote Start ---  

I solved this problem by putting an extra \ at the end of the path. i.e. C:\altera\13.1\modelsim_ase\win32aloem 

 

Hopefully that is useful to someone. 

--- Quote End ---  

 

 

 

 

This is something many not aware of !!
0 Kudos
Altera_Forum
Honored Contributor II
8,412 Views

 

--- Quote Start ---  

I solved this problem by putting an extra \ at the end of the path. i.e. C:\altera\13.1\modelsim_ase\win32aloem 

 

Hopefully that is useful to someone. 

--- Quote End ---  

 

 

Thanks for sharing your resolution.
0 Kudos
Reply