Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14961 Discussions

DDR3 megawizard generation error in Quartus 20.1.

New Contributor I

I just did a second clean install of Quartus 20.1. I'm on Win7 64bit with 8gb ram. All I did was open Quartus in the IP catalog and did a +create. In an empty folder, I specified the Verilog name and memory settings and then 'Finish'.

I've attached a screenshot of the Errors. The errors go down for pages.

6 Replies
Honored Contributor III

Windows 7 is no longer supported, so there's no guarantee that anything would work:

New Contributor I

Thank you  for your reply sstrell.

My friend is getting the same error in Win10.

I personally am not allowed to upgrade to Win10 at this point in time.  How many versions of Quartus do I need to go back to get functionality?  I already know Quartus 18.1 also doesn't work as I just recently upgraded Q20.1 to see if it could fix the issue.



Okay, I've got a successful build of the DDR3 SDRAM controller with UniPHY in Quartus 20.1 in Windows 10.

It definitely needs Windows Subsystem for Linux installed - it appears there's no way for the megawizard to work without it, hence why it's not supported on Windows 7.  Don't ask me why Linux is a requirement for it - there's nothing there that Windows can't do, so I'll chalk that up to plain obfuscation on the part of the developer.

Although my Windows 10 had WSL installed before, I followed steps 1-3 here (although they were likely unnecessary), but most importantly the megawizard's error log was telling me there was no 'wsl' or 'dos2unix' commands - this could only have been in bash as the error report suggested a "sudo apt-get", so I installed them in bash as well.

I ran the megawizard and it successfully compiled the controller with no errors.

Given the discussion here though, there's no guarantee we'll be able to use it anyway.



I have the same problem with the DDR3 controller in Quartus 20.1.1., but im not the familar with the LINUX WSL. So what you mean with: "so I installed them in bash as well." What I have to do after step 1-3 from the Microsoft site


Hi JStan7,

I'll assume you're using Windows 10 with the Windows Subsystem for Linux installed.  Go to the task bar, click the search icon (magnifying glass), and type 'bash'.

The top result should be 'Bash on Ubuntu on Windows'.  Click on that link and a console window will open into bash.  This is a Linux console, running on Windows.  Once you're here, you can install the necessary software by typing 'sudo apt-get wsl' and 'sudo apt-get dos2unix'.

Doing this seemed to fix the errors for me.


Hi nockieboy,

I have done the following:

  • step 1-6 from the microsoft site with installing Ubuntu 20.04LTS
  • opening a bash and type in the following commands
    • sudo apt update
    • sudo apt install wsl
    • sudo apt install dos2unix
    • sudo apt install make

And now the DDR3 megawizzard runs without errors; very tricky!!

Special thanks for your help