Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yjian16
Beginner
1,458 Views

Disable output of profile.mon

I was using the AOC to generate the .aocx file. When I run the aocx file, I do not want to generate the profile.mon file. How should I do? please help me!

when I compile the .cl, I have remove the -profile parameter. But when I run the aocx file , there is still profile.mon generated. My AOC version is 17.1.1

0 Kudos
3 Replies
Nooraini_Y_Intel
Employee
75 Views

Hi,

Currently I am reviewing the forum for any open questions and found this thread. I apologize that no one seems to answer this question that you posted. Since it has been a while you posted this question, I'm wondering if you have found the answer? If not, please let me know, I will try to assign/find someone to assist you. Please do expect some delay in response as most of our agents are out of office due to the year-end holidays. Thank you.

Regards,

Nooraini

yjian16
Beginner
75 Views

Hi

thanks for your attention!

In fact I did not get the answer! I want to know that my operation to remove the --profile is right or not!

 

 

 

75 Views

Hi,

 

To enable the profiling for OpenCL kernel we need to add "-profile=(all|autorun|enqueued)' to you aoc command.

For example aoc -profile=(all|autorun|enqueued) <your_kernel_filename>.cl 

After that during host execution it will create "profile.mon" file with profiling data.

 

Now in your case since you don't want to generate profile data, make sure you clean your previous compilation results and delete older "profile.mon" as well.

 

  • Recompile you kernel, aoc -v -board=<board_name> device/hello_world.cl -o bin/hello_world.aocx
  • Flash fpga with kernel programming file aocl flash <device_name><design_example_filename>.aocx
  • Re-create host executable file.
  • Run host file.

 

Let me know if you have any questions.

 

Thanks,

Arslan

 

Reply