Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16594 Discussions

Error when setting password - Feature not implemented or unavailable under current execution privile

alexislms
Valued Contributor I
1,439 Views

alexislms_0-1675654183549.png

 

jtagconfig to run jtagd: Error when setting password - Feature not implemented or unavailable under current execution privilege level

 

Please advise. The whole behavior of jtagd and jtagconfig is obscure and we don't understand anything, there is no help, no documentation regarding these binaries.

0 Kudos
1 Solution
alexislms
Valued Contributor I
1,391 Views

@sstrell That's exactly what I've done. There is no valid reason to run any of the jtag* commands as root.

 

After trying again and again after reboots and all, it has stopped returning this error.

 

It would still be good to know why I got this error message.

View solution in original post

0 Kudos
6 Replies
sstrell
Honored Contributor III
1,410 Views

It looks like you are trying to set up a JTAG server and need a password.  Put -h after jtagconfig for info.

All the available options correlate to options in the GUI so check the Programmer user guide:

https://www.intel.com/content/www/us/en/docs/programmable/683039/22-3/the-jtagconfig-debugging-tool.html

0 Kudos
alexislms
Valued Contributor I
1,407 Views

"need a password" for what?

 

The help doesn't really help...

JTAG Server Configuration

Usage: jtagconfig [--enum]
jtagconfig --add <type> <port> [<name>]
jtagconfig --remove <cable>
jtagconfig --getparam <cable> <param>
jtagconfig --setparam <cable> <param> <value>
jtagconfig --define <jtagid> <name> <irlength>
jtagconfig --undefine <jtagid> <name> <irlength>
jtagconfig --defined
jtagconfig --addserver <server> <password>
jtagconfig --enableremote <password>
jtagconfig --disableremote
jtagconfig --version
jtagconfig --help
jtagconfig --extrahelp

For more details use jtagconfig --extrahelp

 

And for enableremote:

--enableremote Tells the JTAG server to allow connections from remote
<password> machines. These machines must specify the same password
when connecting.

 

As you can see in the screenshot, the password is provided "mypass".

 

Then, why do I get this error message?

 

As you can imagine, I follow this page: https://www.intel.com/content/www/us/en/docs/programmable/683472/22-4/installing-and-configuring-a-local-jtag.html

 

Thanks.

0 Kudos
sstrell
Honored Contributor III
1,405 Views

You run --enableremote on the machine you want to act as the JTAG server, setting the password that others will use to connect to it.  On other machines that want to connect to this machine as a server, they use --addserver, setting the address of the server and the password that was set.

As for the error, perhaps you have to run it as sudo.

0 Kudos
alexislms
Valued Contributor I
1,392 Views

@sstrell That's exactly what I've done. There is no valid reason to run any of the jtag* commands as root.

 

After trying again and again after reboots and all, it has stopped returning this error.

 

It would still be good to know why I got this error message.

0 Kudos
NurAiman_M_Intel
Employee
1,349 Views

Hi,


You need to run it in administrator mode to avoid the error.


Regards,

Aiman


0 Kudos
NurAiman_M_Intel
Employee
1,318 Views

I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


0 Kudos
Reply