Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
790 Views

Every time I modify parameter of IP component, other components becomes "IP upgrade required" status.

​When I modified output frequency of ALTPLL, I saw this kind of message. When I modified width of LPM_MUX, in this time, ALTPLL becomes "IP upgrade required" status.

 

This is very annoying :(

 

ip_upgrade_needed.png

0 Kudos
3 Replies
Highlighted
29 Views

Hi BLee15, 

What Quartus Tools Edition and Version are you using?

Any IP variations that you generate from a previous version or different edition of the Quartus® Prime software, may require upgrade before compilation in the current software edition or version.

The Project Navigator displays a banner indicating the IP upgrade status. 

Click Launch IP Upgrade Tool or Project > Upgrade IP Components to upgrade outdated IP cores.

Refer to the link below.

https://www.intel.com/content/www/us/en/programmable/documentation/eis1410764818924/eis1410936966508...

Thanks. 

0 Kudos
Highlighted
New Contributor I
29 Views

I think I forgot to menthin version information.

 

I'm using Quartus Prime Lite v18.0.0

Project and IP components are created from the same version.

I'm using MAX 10 family.

 

When I did IP upgrade, the message disappears. However, every time I'm modifying parameters of one IP component (like frequency of PLL), other components (MUX in this case) immediately becomes "upgrade required" status again.

Highlighted
Beginner
29 Views

I've seen this issue as well. I believe it happens with both v17 and v18 tools. I'm using a Cyclone V FPGA with the Standard Edition tools.

0 Kudos