Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15544 Discussions

How to disable a specific warning

OHarb1
Novice
750 Views

I get megabytes of this warning.

 

What does it mean?

 

Can I disable it?

 

Warning (14320): Synthesized away node "top|fiddlybob|memory_rtl_1|auto_generated|q_b[4078]" File: /workspace/[deleted]/tmp-clearbox/top/975/altsyncram_v8j1.tdf Line: 114222

 

0 Kudos
1 Solution
Kenny_Tan
Moderator
662 Views

There seems to be noway to do it without GUI.

 

We do have message suppression manager . It is a form of *.sff that recognized by the quartus. https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/qts/qts_qii52012.pdf but it GUI to handle the import and export.

 

looking into quartus_sh --qhelp -> report, it seems does not have this feature as well.

 

I will file an enhancement feature to our developer.

 

 

View solution in original post

8 Replies
Kenny_Tan
Moderator
662 Views

This means that this node is not connecting to anythings. you will have to check the connection in your design.

 

You can suppress message by right click on the messages -> suppress

OHarb1
Novice
662 Views
  1. The warning is in code generated by Quartus: "altsyncram_v8j1.tdf". I can't connect the dots from what I did to getting this warning.
  2. I'm not using the user-interface, this is from a build server. I would like to suppress the files from the build log. Is there an option or tcl command to stop this warning from appearing during P&R?
Kenny_Tan
Moderator
662 Views
OHarb1
Novice
662 Views

Do you know what the option is called?

 

There are 41 references when I search for "warning", but none of them are about how to disable warnings.

Kenny_Tan
Moderator
662 Views

look for the keyword of suppress 

OHarb1
Novice
662 Views

All I found was this option, it's not precise enough to suppress individual messages:

 

-suppress_messages

 

Specifies whether or not to suppress simulator specific information and warning messages issued during compilation. This option does not apply to tool specific error messages. Messages that are suppressed do not appear in a log file, if one was specified. If this option is not specified, then no messages are suppressed.

Kenny_Tan
Moderator
663 Views

There seems to be noway to do it without GUI.

 

We do have message suppression manager . It is a form of *.sff that recognized by the quartus. https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/qts/qts_qii52012.pdf but it GUI to handle the import and export.

 

looking into quartus_sh --qhelp -> report, it seems does not have this feature as well.

 

I will file an enhancement feature to our developer.

 

 

OHarb1
Novice
662 Views
Reply