Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JKoty
Beginner
159 Views

I would ask for help with error message when .qar file is generated.

Hi

I would ask for help with issue.

I have Quartus Pro edition 18.1 build 222.

 

When I run command:

 

project_archive c10_pcie.qar -include_libraries

 

from .tcl file system return me error message:

 

Info: ----------------------------------------------------------

Info: Generated archive 'c10_pcie.qar'

Info: ----------------------------------------------------------

Info: ----------------------------------------------------------

Info: Generated report 'c10_pcie.archive.rpt'

Error (125085): The Quartus Prime Settings File changed outside of the Quartus Prime software and contains errors. Rewriting the Quartus Prime Settings File with the current state of assignments in the Quartus Prime software.

Error (293007): Current module quartus_sh ended unexpectedly. Verify that you have sufficient memory available to compile your design. You can view disk space and physical RAM requirements on the System and Software Requirements page of the Intel FPGA website (http://dl.altera.com/requirements/).

 

Sript was run it on notebook with memory 16GB but also on server cluster with 32GB and enough CPU resources.

 

Do you have tips how to solve his issue?

0 Kudos
8 Replies
SyafieqS_Intel
Moderator
70 Views

Hi Jan,

 

The error showed due to not matching the system requirement. Make sure you match all the specifications e.g OS, RAM depending on targeting device. Refer to link below for details.

https://www.intel.com/content/dam/altera-www/global/en_US/others/download/os-support/readme-qp181.tx...

 

https://fpgasoftware.intel.com/requirements/18.1/

 

Thanks,

Regards

JKoty
Beginner
70 Views

Hi,

I double check that we are matching all system requirements. We now are run on Centos 7 OS, which is binary compatible with Read Head 7. We are running on this OS all others build with .qar part of code (For Quartus standart Edittion) and all is right. Do you know about any reasons why Quartus Pro editions shouldn't run on this OS?

 

Best Regards

Jan

JKoty
Beginner
70 Views

I spoke with IT department in our company and we are sure, that we are fulfill all system requirements for Quartus 18.1 Pro with Cyclone 10 device. It is error which is for our product showstopper.

 

J.

SyafieqS_Intel
Moderator
70 Views

Hi Jan,

 

Could you provide the .qar file and steps how you you were getting the error for me to replicate it.

 

Thanks,

​​​​​​​Regards

JKoty
Beginner
70 Views

Hi, I am preparing for you dummy project where should be reproducible our issue. How I should share it with you? It is not good idea to share it on public forums. Best regards Jan
SyafieqS_Intel
Moderator
70 Views

Hi Jan,

 

You can use email feature there..

JKoty
Beginner
70 Views

Hi, I removed almost all from the our project and there is only part of our framework and design only with PCIe HARD IP. Inside archive is build project to save some time from your side. To reproduce our issue you need have all tools in Paths (We are now using Quartus Prime Version 18.1.0 Build 222 09/21/2018 SJ Pro Edition ) and run only target "Archive project" in impl/c10_pcie/impl.tcl. Now are UN-Commented ALL targets for case you would like to see all steps. We are run impl.tcl by type "make compilation"

I believe that you will be able to reproduce it.

 

Best regards

Jan

JKoty
Beginner
70 Views

Hi,

 

it is looks like we found solution, is not tested on server yet but on PC is looks good. We updated Quartus 18.1.0 to 18.1.2.

 

Regards

Jan

Reply