Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15339 Discussions

Input signal pin as global clock

Altera_Forum
Honored Contributor II
1,405 Views

I have a Wavesshare EP4CE10 development board and want to input a 10MHz clock to go in as a global clock. 

 

 

Unfortunately, the dev board seems to have only one clock input physically accessible on the pcb (BGA device).  

 

 

I would like to try use one of the normal IO pins and internally steer this input to one of the internal global clock signals. Assignment Editor (assignment name) setting the input pin to "global" gives me an error.  

 

Any way to do this?  

 

 

Could try generating some internal logic eg a mux. But don't know how to set this internal node as global clock.  

 

PS using VHDL 

Also compilation reports shows the signal, not as "global" but as "non-global high fan out" so its seems it is not being automatically assigned as global!
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
180 Views

Hi, 

 

If you use IO pin as Clock, for example, let's say PLL you will get an error, 

You can use PLL with input 10MHz and generate the required clock. 

Go through the link below which may help you, 

https://www.altera.com/support/support-resources/knowledge-base/solutions/rd03182011_985.html 

Follow the steps below to make the assignment:in the Assignment Editor:1) Create a new assignment in the Assignment Editor and then set:Assignment Name = Global Signal 

Value = Global Clock  

Enabled =Yes  

To = <node name> (For example, use the node finder to locate the node name of the PLL output clock such as "pll1:inst|altpll:altpll_component|pll1_altpll:auto_generated|wire_pll1_clk[0]") 

2) After the assignment is created, the assignment list will be updated. 

 

3) Recompile the design.  

 

4) After compilation, verify your assignment by viewing the "Global and other fast signals" report under Fitter > Resource Section > Global & Other fast signals. You will see thatthe output clock is now connected to a Global Clock. 

 

When entering an assignment in the .qsf file follow these steps: 

 

1) Open the .qsf file and add the following:set_instance_assignment -name GLOBAL_SIGNAL "GLOBAL CLOCK" -to "<node name>"  

 

2) Recompile the design.  

 

3) After compilation, verify your assignment by viewing the "Global and other fast signals" report under Fitter > Resource Section > Global & Other fast signals. You will see thatthe output clock is now connected to a Global Clock. 

[/INDENT] 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance. 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor II
180 Views

Thanks very much, that did the trick 

 

The (non obvious) solution was adding the three entries as shown below, I was only entering the first!  

Assignment Name = Global Signal 

Value = Global Clock  

Enabled =Yes
Altera_Forum
Honored Contributor II
180 Views

Yes, for any assignment in Assignment Editor, you have to set the target, the type of assignment, the value, and make sure it is enabled. You'll see a green checkmark if the assignment is set up correctly.

Reply