Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
889 Views

MAX10 programmed with POF won't start

Device in question is 10M04SCE144.  

 

I am using Altera's for last 30 years or so, so I am pretty familiar with it. Now I have a new project, using MAX10 device for the first time. I've downloaded Quartus 17.1 Lite, created a test project (blinky) which works when SOF file is downloaded. However, whatever I do, I can't get it running when I program device with POF file ( programming and verifying completes without errors, btw). Please note that the configuration-related pins are disabled (all in user I/O mode). 

 

I guess I am missing something, but can't figure out what can it be, so any help/suggestion is highly appreciated.
0 Kudos
8 Replies
Altera_Forum
Honored Contributor I
61 Views

What is your configuration setup? Are you saying you're putting the .pof in the on-chip flash? More details necessary, I think.

Altera_Forum
Honored Contributor I
61 Views

 

--- Quote Start ---  

What is your configuration setup? Are you saying you're putting the .pof in the on-chip flash? More details necessary, I think. 

--- Quote End ---  

 

 

Yes, I am putting .pof file into on-chip flash. Regarding configuration settings, see attached screenshots. 

 

I have installed Q17.1-lite. Is there any limtation regarding .pof file creation with .-lite versions? For older releases, used WEB-editions, which does not exist for 

Q17. Perhaps that's the reason, or...?
Altera_Forum
Honored Contributor I
61 Views

Your screenshots are too small to see. What is your Programmer setup?

Altera_Forum
Honored Contributor I
61 Views

 

--- Quote Start ---  

Your screenshots are too small to see. What is your Programmer setup? 

--- Quote End ---  

 

 

I've posted full-resolution images in PNG format. For some reason they are shown smaller than they really are if you just click on them. 

Now I tried again with JPG - it seems to be OK.
Altera_Forum
Honored Contributor I
61 Views

OK, so what is your Programmer setup?

Altera_Forum
Honored Contributor I
61 Views

 

--- Quote Start ---  

OK, so what is your Programmer setup? 

--- Quote End ---  

 

 

See attached screenshot, although as I said - programming & verification passes without errors...
Altera_Forum
Honored Contributor I
61 Views

I'm pretty sure you should have only the checkbox for the CFM0 enabled in order to put the .pof into it and then reset the device.

Altera_Forum
Honored Contributor I
61 Views

OK - mistery solved. It was a missing pull-up on CONF_DONE pin. Missed that part of the configuration guide and (wrongly) assumed that if the pins are programmed as user I/O they have no function during configuration...:(

Reply