Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
15775 Discussions

ModelSim not found in executable Quartus 2

fpgamodelsim
Beginner
322 Views

Hello,

I know that I had two issues that were relevant to VHDL. I know that one of them is that when I compiled the Quartus 2 program, I found out that ModelSim was not found in the executable for Quartus 2 (this was an error message). I know that I found not find the reason why it said that ModelSim was not found in the executable when I created a schematic diagram of a flip flop, and compiled the program and set simulations. I know that I received ModelSim not found in executable for Quartus 2. I know that I tried to fix it, but the Quartus 2 program got messed up even though it compiled well in the first place. Maybe I should change the file name and redraw the flip flop, and try to recompile the file again.

Does anyone know why it would say ModelSim not found in executable when I do a Quartus 2 simulation? Does anyone know where this applies?

Secondly, I know that I did try to run and compile files for adders and the waveform simulation did not display the output for the waveform simulation. I know that I tried to click Add Wave, or anything that could cause a wave to get added for the waveform simulation. I know that this did not work at all. It also said that there was an invalid grid period, and I don't know how to fix it. It did also say that the window was closed off in some message. I was unable to fix the waveform simulation and could not display the output. I have no idea why this happens. Could anyone explain the situation to me? Does anyone know how to fix a waveform simulation to display an output for a particular adder like a CarryLookahead or a Bit Adder? I know that this shocking thing did affect my program like a permanent problem. Please let me know how to fix a waveform simulation that does not display output for an adder, so that I could get a proper waveform simulation output for that same adder.  I know that add wave, and view wave did not work to my advantage. I know that I tried view wave, and that did not work. Does anyone have any other alternatives as well. I needed to fix this problem. Please let me know as soon as possible. I truly appreciate your help.

0 Kudos
3 Replies
ak6dn
Valued Contributor III
296 Views

You don't say what variation (Lite, Standard, Pro) or version (like 19.0) of Quartus that you are using.

Nor do you way on what platform you are running (Windows 10, Linux).

Normally ModelSim is a separately installed download. Was it installed on your system?

Much more info is needed about your configuration before comments can be made on how to proceed.

RichardTanSY_Intel
281 Views

Regarding the executable issue, have you set up your EDA Tool Settings in the Quartus software?

https://www.intel.com/content/www/us/en/docs/programmable/683248/18-0/specify-eda-tool-settings.html


Next, I recommend that you go through the tutorial that is available in the Quartus Simulation Waveform Editor > Help> Simulation Tutorials > PDF Tutorial for Verilog/VHDL users. To get an understanding on how the simulation flow works and compare it to your project to check where goes wrong.

You may find it in the Quartus installation directory.

<quartus installation path>\quartus\common\help\tutorial_quartusii_simulation_verilog.pdf


RichardTanSY_Intel
270 Views

I have yet to receive any response from you to the previous question/reply/answer that I have provided but I believed that I have answered your question. 

With that, I will now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Best Regards,

Richard Tan


p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 


Reply