Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14966 Discussions

Programmer/Altera JTAG Server Not Detecting USB Blaster

xariswon
Beginner
943 Views

Hello everyone,

For the last week or so, I have been unable to see my board connected via USB Blaster in the Altera programmer. I occasionally see it right after rebooting my computer, but it disappears after a few minutes. 

Configuration: I am working with Altera Quartus 18.1 Lite, programming a DEO Nano board with a Cyclone IV FPGA. I'm running Windows 10, 64 bit, version 2004. I can see the device normally on my laptop, so I know it isn't the cable or the Nano hardware. I haven't installed anything new recently other than the Windows 10 2004 update, and everything was working normally a few weeks ago when I last programmed devices. 

In Device Manager, it shows up as "Altera USB-Blaster", and the installed driver points to the appropriate driver in the Quartus install folder.

In the programmer window->Hardware Setup->JTAG Settings, I see no local server listed, while on my laptop it shows a local server. However, when I check the server using jtagconfig.exe --serverinfo, everything appears fine:

Installed JTAG server is 'C:\intelFPGA_lite\18.1\quartus\bin64\jtagserver.exe'
Service manager reports server is running
Server reports path: C:\intelFPGA_lite\18.1\quartus\bin64\jtagserver.exe
Server reports version: Version 18.1.0 Build 625 09/12/2018 SJ Standard Edition
Remote clients are enabled

(Note: I enabled remote clients to see if I could "remotely" connect to my local server; it made not difference)

Finally, I checked if the server saw connected devices; it did not: 

jtagconfig.exe --enum
No JTAG hardware available

I've tried restarting the server, reinstalling the drivers, and even totally uninstalling and reinstalling Quartus. No change. Also tried running as administrator and running with compatibility settings without effect.

Any advice people have would be most appreciated. Thank you all in advance.

0 Kudos
5 Replies
xariswon
Beginner
941 Views

One followup from further research: I added the jtag server as an exception for the firewall, though I didn't get any errors to indicate it was being blocked, with no effect.

YuanLi_S_Intel
Employee
905 Views

Hi,


Is the JTAG working weeks before that? Any idea what are the changes to the PC right before the JTAG stop working?


Can you try to reinstall the JTAG?


Thank You.


Bruce


xariswon
Beginner
710 Views

Sometimes the JTAG will work for a few days before it stops, sometimes only a few minutes. I have not found any particular pattern, like "after connecting this particular device" or "after running this particular software".

I have *attempting* to completely uninstall and reinstall JTAG (and all of Quartus); however, it appears to use multiple drivers, so I am not 100% certain whether I am getting everything relevant. 

Gerardo1
Beginner
716 Views

Hi, I'm having the same problem. Did you find a solution??

 

Cheers

xariswon
Beginner
709 Views

Well, calling it a "solution" would be a stretch, but what I eventually did to move forward was load a clean Windows 10 VM with nothing but a Quartus install. I setup the programmer cable to pass through to the VM, and load firmware updates from there. It's ridiculous but it works. 

Reply