Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16606 Discussions

Quartus 13.1 doesn't work on Linux Mint 21 anymore

MilanJ
Beginner
491 Views


The Quartus in version 13.1 (64 Bit) don't run on Linux Mint 21 anymore. (I need this old version because newer versions doesn't support cyclone3) On Linux Mint 20.3 it worked after I add an old additional libpng12 library to the system. But now on Mint 21 the quartus syntheser (quartus_map) starts compiling a project but never get ready.

 

0 Kudos
5 Replies
ak6dn
Valued Contributor III
477 Views

Well, when you are running 10 year old software that is out of support and will never be updated, expect to make some compromises. You may be restricted to using older software environments (ie, an older version of Linux or Windows) compatible with the software.

You should be happy that it runs on Mint 20.3, which was released in January of this year 2022.

From their website:  "Linux Mint 20.3 is a long term support release which will be supported until 2025."

Go back to 20.3. And stay there if you want to keep using Quartus 13.1.

 

0 Kudos
RichardTanSY_Intel
469 Views

Does the Quartus work in Linux Mint 21 before?

You may check the readme.txt in the Quartus installation directory to check the OS supported with the respective Quartus. [System Requirements - Operating system support].

I take a quick glance and the current supported OS for Quartus 13.1 are:

* Windows 7 (64 and 32 bit)

* Windows XP SP2 (64 and 32 bit)

* Windows XP Pro X64 Edition

* Windows Server 2008 R2 (64 bit)

* Windows 8 (64 bit)

* Red Hat Enterprise Linux 6 (64 bit)

* Red Hat Enterprise Linux 5 (64 and 32 bit)

 

I am not familiar with Linux Mint 21 but it seems that it is not officially supported.

 

Best Regards,

Richard Tan

 

0 Kudos
ak6dn
Valued Contributor III
464 Views

I think the word 'anymore' in the title is a red herring.

He said Quartus 13.1 worked fine on Mint 20.3 when he added a missing file.

When he upgraded to Mint 21 it stopped working.

So don't do that.

You can't expect legacy software to work on the latest new release of some OS, whether Windows or Linux.

Go back to Mint 20.3. And stay there for your development system.

Or build a VM with Mint 20.3 installed and run Quartus in that VM.

Problem solved.

0 Kudos
RichardTanSY_Intel
451 Views

May I know does your question answered? Do you need further help?


Best Regards,

Richard


0 Kudos
RichardTanSY_Intel
425 Views

As we do not receive any response from you on the previous question/reply/answer that we have provided. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.

 

Thank you.

 

Best Regards,

Richard Tan

 

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 9/10 survey.


0 Kudos
Reply