Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16728 Discussions

Signal Tap invalid JTAG configuration

Hic20
Beginner
1,123 Views

Hi

I have the problem that I cannot program my MAX 10M16SAE144I7G via the signal tap. It says that the JTAG configuration is invalid. I did use Quartus Prime for some time now, but I never had this error. So far I did create a new stp file,  reinstalled the driver of the USB-Blaster, checked if the JTAG chain is not broken. I checked if the signal tap logic analyzer is enabled and if the signal tap is visible in the hierarchy and in the fitter report. It is all there were it should be. One odd thing I discovered is that if I select the USB-Blaster in the hardware options in the signal tap as i accept and close it, it does scan the chain, but if I revisit the hardware setup "no hardware" is selected again. Maybe someone can encountered this problem and can help me.

 

Thanks in advance

L

Labels (1)
0 Kudos
5 Replies
sstrell
Honored Contributor III
1,097 Views

Start with the Quartus Programmer.  Can you successfully do a standard programming of the device from the Programmer?  

If that works, then you can move on to figure out why Signal Tap is not seeing the connection.  Are you sure that the settings in the .stp file match the Signal Tap instance that's been programmed to the device?

0 Kudos
Ilaria_
Beginner
868 Views

Hi, 

 I have the same problem with my 10m25sa. No problem during programmation by usb_blaster (rev.c) with tool "programmer"(quartus prime lite) = Progression 100% (successful), but "JTAG configuration is invalid" and "instance not found" when I try to use STAP.  I quote "So far I did create a new stp file,  reinstalled the driver of the USB-Blaster, checked if the JTAG chain is not broken. I checked if the signal tap logic analyzer is enabled and if the signal tap is visible in the hierarchy and in the fitter report. It is all there were it should be" 

 

Any ideas? Please help!

 

Thank you in advance.

I.

0 Kudos
NurAiman_M_Intel
Employee
1,067 Views

Hi,


Same with @sstrell, have you try to program the Max10 without signal tap? Does it successful?

Can you try with another USB Blaster?


Regards,

Aiman


0 Kudos
NurAiman_M_Intel
Employee
1,010 Views

Hi,


Any update from my latest response?


Regards,

Aiman


0 Kudos
NurAiman_M_Intel
Employee
929 Views

We do not receive any response from you to the previous answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


0 Kudos
Reply