Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14947 Discussions

The problem about Transceiver Toolkit for testing IP : altera_xcvr_10gkr_a10

Sam_Chang
Beginner
225 Views

Hi all,

I want to test BER in Transceiver Toolkit for altera_xcvr_10gkr_a10,

In IP Parameter, I choose  "Enable Hard PRBS and Native PHY Debug Master Endpoint support"

After compile, in Transceiver Toolkit, I try to use Auto Sweep to loop-back PRBS, but the receiver can't receive any data, so the BER don't have any information.

In the picture, I don't know why I have this yellow warning.

How to solve it.

THANKS!

 

receiver.png

0 Kudos
1 Solution
SengKok_L_Intel
Moderator
170 Views

Hi


If you can use the Native PHY IP will be a great help to narrow down the problem, you may use the 10G base R preset setting in Native PHY IP and then enable the PHY to debug the master port. This can help to rule out if there is any dependency on the BASR KR IP or any design connection relate problem.


Regards -SK


View solution in original post

6 Replies
SengKok_L_Intel
Moderator
215 Views

Hi,


Before using the TTK, does this design working fine with any other traffic test? You might need to double-check your design if there is any clock/reset connection concern.


Regards -SK


Sam_Chang
Beginner
202 Views

I double-check the clock/reset connection is connected 

the problem is still not solved 

SengKok_L_Intel
Moderator
191 Views

Hi Sam,

 

The 10GBase KR PHY IP includes the feature of ethernet standards, when you run the PRBS test, it may cause the receiver to keep resetting.

 

To run the PHY PRBS test, it will be better if you can use the standalone Native PHY IP and configure it as 10G.

 


Sam_Chang
Beginner
186 Views

Hi,

So,I enable the HARD PRBS and Native PHY Debug Master Endpoint Support ,

it still can't run PRBS test, right?

THANKS!

Screenshot from 2020-12-22 08-53-37.png

SengKok_L_Intel
Moderator
171 Views

Hi


If you can use the Native PHY IP will be a great help to narrow down the problem, you may use the 10G base R preset setting in Native PHY IP and then enable the PHY to debug the master port. This can help to rule out if there is any dependency on the BASR KR IP or any design connection relate problem.


Regards -SK


View solution in original post

SengKok_L_Intel
Moderator
150 Views

If further support is needed in this thread, please post a response within 15 days. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 


Reply