Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
2,254 Views

aocl list-devices : No devices attached for package:

When i run "aocl list-devices" command what i get is following output 

 

-bash-4.2$ aocl list-devices 

-------------------------------------------------------------------- 

Warning: 

No devices attached for package: 

<.....>/hld/board/a10_ref 

-------------------------------------------------------------------- 

 

Seems the device is not added properly. What could be the reason.  

Due to this I am not able to program my PAC.
5 Replies
HRZ
Valued Contributor II
431 Views

Please post the environmental variables you have set that are related to the Intel tools. There is likely something wrong with the way you have set the "ALTERAOCLSDKROOT" variable.

JamesR
Black Belt
431 Views

I am having the same problem - and I can provide more details. Perhaps answering my issue will help us both... I have the exact same issue: OpenCL doesn't know about my PAC card.

 

PLEASE help educate us about how to debug/solve this...

(I have ENVIRONMENT variables in NEXT post)...

 

My QUESTION: How do I debug (and solve) a “ERROR: CL_DEVICE_NOT_FOUND” for a system with a PAC card installed?

I think my issue is this: OpenCL can’t find the PAC card.

Here is an example of trying to use it:

 

% ~/inference_engine_samples/intel64/Release/security_barrier_camera_sample -d CPU -d_va FPGA -d_lpr CPU -i /opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/demo/../demo/car_1.bmp -m /opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/demo/../intel_models/vehicle-license-plate-detection-barrier-0106/FP32/vehicle-license-plate-detection-barrier-0106.xml -m_va /opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/demo/../intel_models/vehicle-attributes-recognition-barrier-0039/FP32/vehicle-attributes-recognition-barrier-0039.xml -m_lpr /opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/demo/../intel_models/license-plate-recognition-barrier-0001/FP32/license-plate-recognition-barrier-0001.xml

 

InferenceEngine: 

API version ............ 1.2

Build .................. 13911

[ INFO ] Parsing input parameters

[ INFO ] Reading input

[ INFO ] Loading plugin CPU

 

API version ............ 1.2

Build .................. lnx_20180510

Description ....... MKLDNNPlugin

[ INFO ] Loading plugin FPGA

 

API version ............ 1.2

Build .................. dliaPlugin

Description ....... dliaPlugin

[ INFO ] Loading network files for VehicleDetection

[ INFO ] Batch size is forced to 1

[ INFO ] Checking Vehicle Detection inputs

[ INFO ] Checking Vehicle Detection outputs

[ INFO ] Loading Vehicle Detection model to the CPU plugin

[ INFO ] Loading network files for VehicleAttribs

[ INFO ] Batch size is forced to 1 for Vehicle Attribs

[ INFO ] Checking VehicleAttribs inputs

[ INFO ] Checking Vehicle Attribs outputs

[ INFO ] Loading Vehicle Attribs model to the FPGA plugin

ERROR: CL_DEVICE_NOT_FOUND 

Location: /home/user/teamcity/work/scoring_engine_build/releases_openvino-2018-r3/thirdparty/dla/api/src/AOCL_Utils.cpp:398

Query for number of devices failed

 

Here is evidence that the card is plugged in (with BOARD info and everything!)…

 

% bwconfig --list

There are no mapped devices in your system.

% bwconfig --scan=usb

Scanning for devices

 

[result]: Board Type (Name), Serial, VendorID, DeviceID, USB-Address

[0]:   0x5f (A10SA4)    202101 0x2528  0x0004  0x6

% bwconfig --add=usb --result=0

Scanning for devices

 

[result]: Board Type (Name), Serial, VendorID, DeviceID, USB-Address

[0]:   0x5f (A10SA4)    202101 0x2528  0x0004  0x6

Device added as device "0".

% bwconfig --list

------------------------------------------------------------------------------

Name     Number ID   Location          Status

------------------------------------------------------------------------------

A10SA4    0   202101 Local USB Device      Installed (New)

 

I did this after trying the run, and then tried the run again… NO change, OpenCL still doesn’t see the card… see this:

 

 

% aocl diagnose

--------------------------------------------------------------------

Warning:

No devices attached for package:

/home/james/inteldevstack/intelFPGA_pro/hld/board/a10_ref

--------------------------------------------------------------------

 

Call "aocl diagnose <device-names>" to run diagnose for specified devices

Call "aocl diagnose all" to run diagnose for all devices

 

I’m wondering - is “a10_ref” appropriate for a PAC (Arria 10)? I have NO other board reference files to point to - but the name does concern me. If there are OpenCL files for the PAC card to try… I’m eager to know that.

 

% aocl diagnose all

(no output)

% aocl diagnose 202101

--------------------------------------------------------------------

202101 is not a valid device name.             

--------------------------------------------------------------------

% aocl diagnose 0

--------------------------------------------------------------------

0 is not a valid device name.             

--------------------------------------------------------------------

% aocl diagnose 1

--------------------------------------------------------------------

1 is not a valid device name.             

--------------------------------------------------------------------

% aocl diagnose dev0

--------------------------------------------------------------------

dev0 is not a valid device name.             

--------------------------------------------------------------------

% aocl diagnose dev1

--------------------------------------------------------------------

dev1 is not a valid device name.

 

 

 

JamesR
Black Belt
431 Views

The is a FOLLOW-ON to my notes in the prior post - with environment variables for my version of the issue...

 

My environment variables…

% env

XDG_SESSION_ID=1009

HOSTNAME=psg_pool01

LIBVA_DRIVERS_PATH=/opt/intel/mediasdk/lib64

SELINUX_ROLE_REQUESTED=

TERM=xterm-256color

SHELL=/bin/bash

ALTERAOCLSDKROOT=/home/james/inteldevstack/intelFPGA_pro/hld

HISTSIZE=1000

SSH_CLIENT=192.168.1.29 59894 22

PERL5LIB=/home/james/perl5/lib/perl5:

SELINUX_USE_CURRENT_RANGE=

LIBVA_DRIVER_NAME=iHD

QSYS_ROOTDIR=/home/james/inteldevstack/intelFPGA_pro/qsys/bin

QTDIR=/usr/lib64/qt-3.3

QTINC=/usr/lib64/qt-3.3/include

PERL_MB_OPT=--install_base /home/james/perl5

SSH_TTY=/dev/pts/0

QT_GRAPHICSSYSTEM_CHECKED=1

USER=james

LD_LIBRARY_PATH=/home/james/inteldevstack/intelFPGA_pro/hld/host/linux64/lib:/home/james/inteldevstack/intelFPGA_pro/hld/board/a10_ref/linux64/lib:/home/james/inteldevstack/intelFPGA_pro/hld/board/a10_ref/linux64/lib:/home/james/inteldevstack/intelFPGA_pro/hld/host/linux64/lib:/opt/intel/computer_vision_sdk_fpga_2018.3.343/opencv/share/OpenCV/3rdparty/lib:/opt/intel/computer_vision_sdk_fpga_2018.3.343/opencv/lib:/opt/intel/opencl:/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/inference_engine/external/cldnn/lib:/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/inference_engine/external/gna/lib:/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/inference_engine/external/mkltiny_lnx/lib:/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/inference_engine/lib/centos_7.3/intel64:/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/model_optimizer/model_optimizer_caffe/bin:/opt/intel/computer_vision_sdk_fpga_2018.3.343/openvx/lib:

LS_COLORS=rs=0:di=38;5;27:ln=38;5;51:mh=44;38;5;15:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5;232;38;5;9:mi=05;48;5;232;38;5;15:su=48;5;196;38;5;15:sg=48;5;11;38;5;16:ca=48;5;196;38;5;226:tw=48;5;10;38;5;16:ow=48;5;10;38;5;21:st=48;5;21;38;5;15:ex=38;5;34:*.tar=38;5;9:*.tgz=38;5;9:*.arc=38;5;9:*.arj=38;5;9:*.taz=38;5;9:*.lha=38;5;9:*.lz4=38;5;9:*.lzh=38;5;9:*.lzma=38;5;9:*.tlz=38;5;9:*.txz=38;5;9:*.tzo=38;5;9:*.t7z=38;5;9:*.zip=38;5;9:*.z=38;5;9:*.Z=38;5;9:*.dz=38;5;9:*.gz=38;5;9:*.lrz=38;5;9:*.lz=38;5;9:*.lzo=38;5;9:*.xz=38;5;9:*.bz2=38;5;9:*.bz=38;5;9:*.tbz=38;5;9:*.tbz2=38;5;9:*.tz=38;5;9:*.deb=38;5;9:*.rpm=38;5;9:*.jar=38;5;9:*.war=38;5;9:*.ear=38;5;9:*.sar=38;5;9:*.rar=38;5;9:*.alz=38;5;9:*.ace=38;5;9:*.zoo=38;5;9:*.cpio=38;5;9:*.7z=38;5;9:*.rz=38;5;9:*.cab=38;5;9:*.jpg=38;5;13:*.jpeg=38;5;13:*.gif=38;5;13:*.bmp=38;5;13:*.pbm=38;5;13:*.pgm=38;5;13:*.ppm=38;5;13:*.tga=38;5;13:*.xbm=38;5;13:*.xpm=38;5;13:*.tif=38;5;13:*.tiff=38;5;13:*.png=38;5;13:*.svg=38;5;13:*.svgz=38;5;13:*.mng=38;5;13:*.pcx=38;5;13:*.mov=38;5;13:*.mpg=38;5;13:*.mpeg=38;5;13:*.m2v=38;5;13:*.mkv=38;5;13:*.webm=38;5;13:*.ogm=38;5;13:*.mp4=38;5;13:*.m4v=38;5;13:*.mp4v=38;5;13:*.vob=38;5;13:*.qt=38;5;13:*.nuv=38;5;13:*.wmv=38;5;13:*.asf=38;5;13:*.rm=38;5;13:*.rmvb=38;5;13:*.flc=38;5;13:*.avi=38;5;13:*.fli=38;5;13:*.flv=38;5;13:*.gl=38;5;13:*.dl=38;5;13:*.xcf=38;5;13:*.xwd=38;5;13:*.yuv=38;5;13:*.cgm=38;5;13:*.emf=38;5;13:*.axv=38;5;13:*.anx=38;5;13:*.ogv=38;5;13:*.ogx=38;5;13:*.aac=38;5;45:*.au=38;5;45:*.flac=38;5;45:*.mid=38;5;45:*.midi=38;5;45:*.mka=38;5;45:*.mp3=38;5;45:*.mpc=38;5;45:*.ogg=38;5;45:*.ra=38;5;45:*.wav=38;5;45:*.axa=38;5;45:*.oga=38;5;45:*.spx=38;5;45:*.xspf=38;5;45:

INTELFPGAOCLSDKROOT=/home/james/inteldevstack/intelFPGA_pro/hld

CL_CONTEXT_COMPILER_MODE_ALTERA=3

ModelOptimizer_ROOT_DIR=/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/model_optimizer/model_optimizer_caffe

MAIL=/var/spool/mail/james

PATH=/home/james/inteldevstack/intelFPGA_pro/quartus/bin:/home/james/inteldevstack/intelFPGA_pro/hld/bin:/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/model_optimizer:/usr/lib64/qt-3.3/bin:/home/james/perl5/bin:/opt/bwtk/dhdev/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/james/inteldevstack/a10_gx_pac_ias_1_1_pv/bin:/home/james/.local/bin:/home/james/bin

BWTK=/opt/bwtk/dhdev

PWD=/home/james

InferenceEngine_DIR=/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/inference_engine/share

LANG=en_US.UTF-8

QUARTUS_HOME=/home/james/inteldevstack/intelFPGA_pro/quartus

OPAE_PLATFORM_ROOT=/home/james/inteldevstack/a10_gx_pac_ias_1_1_pv

KDEDIRS=/usr

OpenCV_DIR=/opt/intel/computer_vision_sdk_fpga_2018.3.343/opencv/share/OpenCV

MFX_HOME=/opt/intel/mediasdk

CL_CONTEXT_COMPILER_MODE_INTELFPGA=3

QUARTUS_ROOTDIR_OVERRIDE=/home/james/inteldevstack/intelFPGA_pro/quartus

SELINUX_LEVEL_REQUESTED=

DCP_LOC=/home/demo_user/DCP/1.0_PRC/release_pkg

HISTCONTROL=ignoredups

SHLVL=1

HOME=/home/james

PERL_LOCAL_LIB_ROOT=:/home/james/perl5

PYTHONPATH=/opt/intel/computer_vision_sdk_fpga_2018.3.343/python/python3.6:/opt/intel/computer_vision_sdk_fpga_2018.3.343/python/python3.6/centos7:/opt/intel/computer_vision_sdk_fpga_2018.3.343/deployment_tools/model_optimizer:

LOGNAME=james

QTLIB=/usr/lib64/qt-3.3/lib

XDG_DATA_DIRS=/home/james/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/

SSH_CONNECTION=192.168.1.29 59894 192.168.1.13 22

LESSOPEN=||/usr/bin/lesspipe.sh %s

AOCL_BOARD_PACKAGE_ROOT=/home/james/inteldevstack/intelFPGA_pro/hld/board/a10_ref

XDG_RUNTIME_DIR=/run/user/1001

DISPLAY=localhost:10.0

QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins

INTEL_CVSDK_DIR=/opt/intel/computer_vision_sdk_fpga_2018.3.343

PERL_MM_OPT=INSTALL_BASE=/home/james/perl5

_=/usr/bin/env

 

 

I would REALLY enjoy any feedback/hints/tips on how to debug (and solve) a “ERROR: CL_DEVICE_NOT_FOUND” for a system with a PAC card installed… THANK YOU!!!

HRZ
Valued Contributor II
431 Views

@JRein, I don't think the PAC card is the same as the a10_ref board. The latter is a development board with one bank of DDR3 and one bank of DDR4 while the PAC card has two DDR4 banks. You most definitely need a BSP specific to the PAC card. Contact whoever you purchased the board from to get the respective BSP. Furthermore, it seems you have not even set up your board. You need to program the board via JTAG with a base firmware to enable the PCI-E core before it is detected using aocl diagnose. Intel's documents outline the steps to do so.

JamesR
Black Belt
431 Views

Thank you. Yes, it turns out "PAC A10" is different than "A10 REF" - and I needed "PAC A10." And, the firmware was flashed but with a version that was too old now for the current OpenCL. So, I needed to flash a newer firmware in the PAC card. Once I got the PAC A10 BSP, and flashed the newer firmware (that matches the BSP) - everything worked. A very helpful support engineer at Intel helped me find the right files and everything works now. The key was having the right combination of firmware on the card, OpenCL driver and BSP, and other libraries... and then it all just work. Very nicely indeed.

Reply